Not able to register multisite users (10 posts)

  1. savagemike
    Posted 3 years ago #

    I enabled multisite on my wordpress at ablogteacher.com and the wp-signup page only allows people to sign up as users on that blog, instead of allowing them to create a new blog.
    I need them to be able to create their own blog, which I thought was the entire point of the multisite capability. I followed all the instructions on enabling multisite, and can of course create blogs/users myself, but visitors won't want to have to send an email to me just to create their blog, and of course I don't want to spend every waking moment creating all of these blogs for these people.
    I hope there is a fix.

  2. savagemike
    Posted 3 years ago #

    Update: I cannot create any blogs myself, either. The subdomain doesn't work, and when I attempt to moderate the new blog (activate it) I get an error page that says "are you sure you want to do this? Please try again."

  3. I take it you WERE able to create blogs before? What changed?

    Did you add in a new plugin? Try turning them ALL off.

  4. savagemike
    Posted 3 years ago #

    No actually it's brand new, I only installed it Friday. It's on a dedicated virtual server at Media Temple, using Plesk.

    I turned off all the plugins and attempted to create a new site, but when visiting the site in my browser I get a server default page.

    I'm starting to think it's a subdomain problem, but I can't see how to change it from subdomains to subfolders.

  5. savagemike
    Posted 3 years ago #

    Also, this is a side note, but is there way to have the storage space limit be different on my default or main blog be different from the storage space limits on the sub-blogs?

  6. Plesk. Ugh. Lots of stupid problems with subdomains and plesk. If you're getting the server default page, then your wildcard subdomains aren't pointing to the right place. They need to point to where you installed WordPress (like public_html, NOT public_html/foldername )

    How to switch between subdomain and subfolder

    And upload space.

    Go to Network Admin -> Options and set "Site Upload Space" to what you want the default to be.

    Then go to Network Admin -> Sites, then click edit under the main site - go to Options and change the space for JUST that site.

  7. savagemike
    Posted 3 years ago #

    Okay thanks for your help!
    I'm looking at my zone file and the wildcard subdomains are pointing to the same IP address as the main domain, which to me seems correct. I assume what's meant here is that I also need to add this in Plesk?
    Also, thanks for the tip on the space settings.

  8. savagemike
    Posted 3 years ago #

    I saw that article the other day, and I do have root access but I'm not familiar enough with BASH right now to really do much. I did check the settings in Plesk itself, and added a wildcard to the zone file that way, but the whole thing is a bit mystifying, because I can edit zone files at my Registrar, my media temple account center, and Plesk. I understand that if the nameservers are at media temple then the zone file settings at my registrar should make no difference, right? But what about modifying the zone file in Plesk, which one is used?
    Thanks for all your help once again, I will bone up on my BASh/SSH skills and then attempt this stuff.

  9. Sadly my knowledge on plesk taps out here :( I use cPanel.

Topic Closed

This topic has been closed to new replies.

About this Topic