Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Not able to manually approve user registrations instead of automatically.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have this problem too – I found https://ultimatemember.com/how-to-manually-approve-new-user-registrations-wordpress-site/, but can’t see that works with the current plugin. Is it perhaps not available in the free version

    Thanks

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @adityabakshi729,

    You can enable “Require admin review” in Ultimate member -> User Roles -> your user role e.g member and “Registration Status” dropdown.

    Regards.

    Thank you for a quick & clear answer. That’s perfect!
    Apologies for not noticing it before . . .

    Cheers

    Dexter800

    (@punxsutawney-phil)

    I followed those instructions: You can enable “Require admin review” in Ultimate member -> User Roles -> your user role e.g member and “Registration Status” dropdown.

    But it still allow users to register and auto-access without admin review…

    Dexter800

    (@punxsutawney-phil)

    Ok solved

    Hi,
    You can enable “Require admin review” in Ultimate member -> User Roles -> your user role e.g member and “Registration Status” dropdown.

    Is this only available for paid users?
    If not Can u provide screen cast because I Could not See what you were discussing

    Quote from Dexter800:

    I followed those instructions: You can enable “Require admin review” in Ultimate member -> User Roles -> your user role e.g member and “Registration Status” dropdown.

    But it still allow users to register and auto-access without admin review…

    OK solved

    ———————————————————-

    How did you manage to do that, I am having the same problem and not able to fix this?

    Anyone?

    Thanks!

    Olivier

    Hi @ultimatemembersupport,

    Is there a way to have both op-in AND manual approval for new members?

    kb1234

    (@karenbatten)

    Hi There,
    I have just done a plugin update.

    I enable “Require admin review” in Ultimate member -> User Roles -> your user role e.g member and “Registration Status” dropdown. But it still isn’t waiting for approval.

    Many thanks in advance…

    I am having the same issue. Tried deactivating all the plugins, loaded the twenty fifteen theme. Still will not require ‘admin review’ before allowing access to the site. Any other ideas?

    Hi team!

    Has anyone solved this issue?

    I have everything set up to force the admin review before allowing access and this option is not working correctly.

    The users are automatically approved without admin review.

    Any help would be appreciated.

    Tools version:

    WordPress – Version 4.9.7
    UM – 2.0.21 (Profile Completeness add on installed)

    • This reply was modified 3 years, 1 month ago by lalegamero.
    akliferealty

    (@akliferealty)

    Hi Team

    Figured out a possible solution. It worked for me.

    Step 1
    Ultimate Member>User Roles>Select which role you want and click “Edit”>Registration Options>Registration Status>Select “Require Admin Review”>Go to top of page and click on “Update Role”.

    Step 2
    Ultimate Member>Dashboard>Click on “Purge Temp Files”>Click on “Clear Cache of # Users”

    Should work after this. Whichever browser you are testing from will need to be refreshed.

    Hope this works for everyone else.

    The problem occurs since the transition from 1.18 to 2.0.

    Problem
    Since 2.0 there is a Registration Default Role added to the Registration Form Settings tab.
    Ultimate Member->Settings->tab Registration Form last parameter Registration Default Role.

    The Registration Default Role role value is default. Since you can’t set Registration options for default. It accepts all the registrations without any review.

    Solution
    Change the default role to Member and save the changes.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Not able to manually approve user registrations instead of automatically.’ is closed to new replies.