Support » Fixing WordPress » not able to log in

  • Resolved nkwebdesign

    (@nkwebdesign)


    When I log in to my website. I am redirect to the main page, not the admin page.
    I know I have the correct password because I changed it in the PHP admin.

    Not sure why this is happening.

Viewing 10 replies - 1 through 10 (of 10 total)
  • “@nkwebdesign”

    A quick Google search came up with lots of possible helpful clues:
    https://www.blogginglove.com/wordpress-login-redirect-problem/ Take a look and good luck!

    Thread Starter nkwebdesign

    (@nkwebdesign)

    thanks

    Hi,
    I had this problem 3 times:

    -first one it was needed to hide the /wp-admin/ slug installing wp admin redirect plugin to login.
    -second to hide the xmplr file disalowing it : https://www.wpbeginner.com/plugins/how-to-disable-xml-rpc-in-wordpress/
    -3th go to your permlinks and change them once how ever, later return them as was before (this is not the best option, but was working for me)

    • This reply was modified 1 year, 2 months ago by Yanko.
    Thread Starter nkwebdesign

    (@nkwebdesign)

    littlepackage – didn’t work

    @nkwebdesign
    What didn’t work?

    Thread Starter nkwebdesign

    (@nkwebdesign)

    nope this didn’t work either…

    https://www.wpbeginner.com/plugins/how-to-disable-xml-rpc-in-wordpress/
    -3th go to your permlinks and change them once how ever, later return them as was before (this is not the best option, but was working for me)

    Thread Starter nkwebdesign

    (@nkwebdesign)

    None of those work.
    I clear cookie and tried this on a different browser
    I disable all plug ins
    hide the xmplr file disalowing it :

    What does your .htaccess file say? (BLOCK OUT any identifying information if it has any)

    Thread Starter nkwebdesign

    (@nkwebdesign)

    # BEGIN WordPress
    # The directives (lines) between BEGIN WordPress and END WordPress are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # Wordfence WAF
    <IfModule LiteSpeed>
    php_value auto_prepend_file ‘/home/domainname/public_html/wordfence-waf.php’
    </IfModule>
    <IfModule lsapi_module>
    php_value auto_prepend_file ‘/home/domainname/public_html/wordfence-waf.php’
    </IfModule>
    <Files “.user.ini”>
    <IfModule mod_authz_core.c>
    Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
    </IfModule>
    </Files>

    # END Wordfence WAF

    # Block WordPress xmlrpc.php requests
    <Files xmlrpc.php>
    order deny,allow
    deny from all
    allow from 123.123.123.123
    </Files>

    Thread Starter nkwebdesign

    (@nkwebdesign)

    Okay I had my back up recovered.
    I am now able to get in my website admin.
    But I see that I need to update the PHP and the theme.

    I will have to do those again.

    Closing this post thanks for helping

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘not able to log in’ is closed to new replies.