Support » Plugin: Menu Breadcrumb » Not able to get it to work

  • I have tried all sorts of code to try and get this to work…

    I have entered my Location for my main menu which is Primary, and also tried other ID’s like 254 which is my main menu id, also tried Primary Menu, Main Menu, primary, primary menu, main menu, primary-menu, main-menu and nothing works.

    https://wordpress.org/plugins/menu-breadcrumb/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jonathan Christopher

    (@jchristopher)

    Can you paste the code you’re using to register the Menu?

    Jonathan, I am having similar issues as above.
    Please explain more what ‘Menu Location to use for breadcrumb’. In your tutorial you said ‘(not ID, slug, name)’. It would be very helpful if you explained this more.
    Here is my code

    <?php if ( function_exists( ‘menu_breadcrumb’) ) { menu_breadcrumb( ‘main-nav-menu’ ); } ?>
    <?php
    if ( function_exists( ‘menu_breadcrumb’) ) {
    menu_breadcrumb(
    ‘main-nav-menu’,
    ‘ ยป ‘,
    ‘<p class=”menu-breadcrumb”>’,
    ‘</p>’
    );
    }
    ?>

    I found the answer where to find ‘Menu Location’ name.
    Go to your WordPress Dashboard->Appearance->Menus, then go to the tab ‘Manage Locations’, you should see a table with ‘Theme Location’ and ‘Assigned Menu’, then View Page Source code, and find <select name=”menu-locations[main-nav]” id=”locations-main-nav”>, your Menu Location is ‘main-nav’. Maybe there is an easier way to find that, if there is please share it.
    Other than that the plugin works as expected. Thank you Jonathan for writing and sharing it!

    Similar problem here (WP 4.1.1 multisite install). I’ve tried a variety of things. Here’s my code –

    if ( function_exists( 'menu_breadcrumb') ) { echo 'gotya';}
    // this works so plugin active
    
    if ( function_exists( 'menu_breadcrumb') ) { menu_breadcrumb( 'main-menu');}
    //this not working

    Here are 2 menu locations i tried (thanks IvonaR , would never have got that without your post)

    <select name="menu-locations[top-menu]" id="locations-top-menu"> //top-menu
    <select name="menu-locations[main-menu]" id="locations-main-menu"> //main-menu

    neither locations return any code at all. Shame because this would be very useful plugin. Any suggestions please Jonathan?

    thanks
    ian

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not able to get it to work’ is closed to new replies.