Support » Fixing WordPress » Not able to delete link(s)

  • Upgraded to 2.0.3 few days ago.
    Didnt try to delete any link before that.
    But today, wanted to delete a link but failed.

    I login to the admin control panel.
    Then “Links”, and then “Manage Links”.
    Then i clicked on the “Delete” button next to the link that i wanted to delete.
    The IE/FF page refreshed, but the link is still there.

    Can someone pls help?

Viewing 15 replies - 1 through 15 (of 16 total)
  • By the way, i have not modified link-manager.php before. And the w3 validator showed no error, it said “Passed validation”.

    Still waiting for help!

    Still waiting for help!

    Still waiting for help!

    Still waiting for help!

    Just to warn you, bumping like this isn’t always taken very well on the wordpress forums. It’s probably fairly likely that nobody knows, but try searching the forum for similar threads, or repeat your request with more details. As much information as you can muster.

    See if this plugin corrects your problem: http://txfx.net/code/wordpress/wordpress-203-tuneup/

    maerk: already searched the forum – always did that before posting. but there’s no similar problem. and i guess BUMPING is definitely better than opening a few more same threads. would love to provide more info if someone request, but nobody is asking and i dont know wat other info u/they need.

    HandySolo: already installed that plugin few days ago, after reading other thread abt “not able to delete post” problem. but it still doesnt solve mine. are my steps of deleting a link correct? just click on the “delete” link?

    Have you checked whether it’s been deleted on the list of links on the actual blog?

    are my steps of deleting a link correct? just click on the “delete” link?

    Just tested this on my 2.0.3 blog (sans plugin). I click delete by the link I want to get ride of. I get a dialog box prompt asking if I’m sure. Nifty little dhtml fader “fades out” the link and it is gone forever.

    Are you getting that dialog box prompt?

    Do you have any FF extensions that might block it?

    maerk: the link stays on the “Link Manager” page, as well as the blog.

    HandySolo: Oh! I didnt get the pop-up! When i clicked on the “delete” link, my IE and FF refreshed itself (didnt show any pop up msg), but after refreshing, the link is still there. I didnt enable the “block pop up” option in both IE and FF, and i even tried to disable my antivirus (i dun hv any firewall). Hmmm, what could be the problem? (I’ve installed the tune-up plugin though, does it disable the pop up?)

    The tune-up plugin shouldn’t be blocking a dialog no.

    Out of curiosity, do your browsers have Google/Yahoo/MSN Toolbars installed? Those also have some popup blockers built-in (yes, I’m grasping… can’t think of a reason why else that dialog would be clobbered.) Javascript enabled on both?

    Nope, dun hv any of those toolbars, dun hv other toolbars as well. And yup, Javascript enabled. And didnt modify the code of the manage link’s php.

    Maybe i’ll go try on another machine later and see if it works.

    Moderator Michael Adams (mdawaffe)

    (@mdawaffe)

    Member

    A bug in 2.0.3 prevents you from deleting links unless javascript is enabled.

    UPDATE: Mark Jaquith has updated his tuneup plugin to fix this issue (Rock on Mark). Download the new version: 0.4.

    http://txfx.net/code/wordpress/wordpress-203-tuneup/

    I had the same problem. No pop-up window, just a refresh.

    I also disabled Firefox extensions but didn’t work.

    I had to delete the link manually through a MySQL interface.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Not able to delete link(s)’ is closed to new replies.