Support » Plugin: Smart Slider 3 » Not able to customisze button

  • Resolved fh4545

    (@fh4545)


    Hello,

    I have been struggling for several hours with slide customazations which normally takes 20 minutes or so. I have tried so many different ways and by now seen that I will not be able to make it happen, which I am not very pleased with, because I would normally not waste your time with something so simple.

    I have created some slides at the home page of our new web store, and I have some text and a button under our branding. The text looks OK at desktop and smartphone but at tablets the text is going to high and hereby into the branding.

    The button hit the navigation dots on smartphones, even it look fine in the settings. Finally, the color of the button and the hover over color have nearly drived me mad. I have tried everything I can come up with I even did the below code, which change the color in “Inspect Elements” but not when I am using it in our Additional CSS. I took my frustration so far that I set the background color and hover over color in the default color, in the main smart slider 3 settings to the colors I want for these buttons, but no luck at all.

    /*Adjust Buttons in Slides*/
    div#n2-ss-3 .n2-style-6ba9ba9c765af7300ba6577369c7ce44-heading {
        background: #4A89B8;
        opacity: 1;
        padding: 12px 28px 12px 28px;
        box-shadow: none;
        border-width: 2px;
        border-style: solid;
        border-color: #4A89B8;
        border-color: RGBA(240,85,43,1);
        border-radius: 99px;
    }

    Please help me out,

    Thank you and best regards,
    Finn

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @fh4545

    1) Hover color
    Are you trying to set one for your button?
    Visit layer window > Design tab > and switch to Hover mode at Style – Button: https://imgur.com/pRqAKpk

    2) Tablet view
    I couldn’t really reproduce this problem on an emulated tablet via Chrome or on my real tablet. (The text was very close to the logo, though.)
    Although I find it possible that the layers and the branding on the background overlap on some devices, as the background was made to cover the slide while the layers were made to be on top of the background.
    For your specific case the best solution would be having the branding logo (FlashPoints) and the blue-white background as separate images. Then you could use the “empty image” as the slide background, and the logo as an image layer. This way you could make sure that the other layers never overlap it.

    fh4545

    (@fh4545)

    Hi Ramona,

    Thank for your reply.

    I have managed to get it right, except for one strange issue. At this stage we need three slides and when I disable the other slides, which was the first slides I did, the slideshow change on smartphones from being showed in portrait to landscape. When I publish one of the first slides I did it change back to being shown in portrait. I have checked the settings between the first slides I did and the new one and I can’t find any settings which are different. I hope you will be able to help me out with this weird behavior.

    Thank you and best regards,
    Finn

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @fh4545

    Your problem is probably related to the default behavior of Content mode.
    ( Here you can check the behavior of our two modes Canvas and Content mode:
    https://smartslider3.helpscoutdocs.com/article/1522-canvas-vs-content-mode )

    So when you use Content mode:
    -the Slide size what you specified at Slider Settings > Size tab:
    https://smartslider3.helpscoutdocs.com/article/59-slider-size
    can be overridden, if you have at least one slide in the slider that requires a bigger space than the one you specified. So in Content mode the height of the slider will be increased if your content is higher then the specified Slider size.

    Here is an example:
    -let’s say you have a wide slider with long texts that fit into this area
    -on smaller screens the same text needs to be wrapped multiple lines. ( A text that was 6 lines long on a wide screen, can be 20 lines long on a smaller screen, which will probably need a higher space. This will make the whole slider so all of its slides higher on small screens. )

    So I assume in your case, the content on that slide ( what you unpublished ) didn’t fit into the specified slider size.

    To fix the problem what you could probably try, is adding some top and bottom padding for the Content layer
    https://smartslider3.helpscoutdocs.com/article/1480-content-layer
    only for mobile view. So that could increase the height of the slider on mobile view.

    Ps.:
    In the Pro version we have options to set device specific slider sizes as you see in our documentations:
    https://smartslider3.helpscoutdocs.com/article/59-slider-size
    however on this forum we can provider help for only the Free version.
    So if you are a Pro user or you have a question related to this Pro feature, please rather open a support ticket at:
    https://smartslider3.com/contact-us/support/?ref=https://wordpress.org/support/topic/not-able-to-customisze-button/

    Best regards,
    Laszlo.

    Hi Lazlo,

    Thank you for your follow-up.

    I got a workaround on the issue, I made a new slide using one of the old slides which already was changing the format to portrait on smartphones. Now I have a button on this slide and will need to create some content, so instead of 3 slides, we will run with 4 slides.

    Best regards,
    Finn

    Hello,

    I have also problem with the button size. When I see the previsualizar it looks perfect, but when I put on my web page the button change size and style and looks different (I attachad the link so you can see the slider in the homepage, where the button are in wrong dimension, never mind if the three of theme has different button design because I was trying different things.

    Web page were the error is

    Thank you very much,

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @cfbancaria

    This topic was already marked as resolved.

    Anyway to find out the problem on your site, please rather open a support ticket at:
    https://smartslider3.com/contact-us/support/?ref=https://wordpress.org/support/topic/not-able-to-customisze-button/#post-11848491
    and attach an export of your slider as you see here:
    https://smartslider3.helpscoutdocs.com/article/370-import-slider

    So we can check how the buttons should actually look like in your slider.

    Best regards,
    Laszlo.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.