Support » Plugins and Hacks » Facebook Comments » Not able to change language

Viewing 4 replies - 1 through 4 (of 4 total)
  • Daniel Bailey

    (@scarinessreported)


    Hi I am away from a real computer at the moment so cannot download to check but it sounds like the plugin is not translated. Search for the .po files that have bg_BG. The other possibility if the plugin is translated is that you havent added the language code to wp-config.php

    Thanks, Daniel. The plugin doesn’t have any .po or .mo files in its folder. And my WP installation is set in Bulgarian in wp-config.php.

    Anyway, isn’t the interface supposed to be pulled from Facebook directly, i.e. so local .po files should not be necessary?

    i found the solution .. in other plugin support ,, and it worked !

    1- first put this code in the head

    <div id=”fb-root”></div>
    <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = “//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1707498062809599&version=v2.0”;
    fjs.parentNode.insertBefore(js, fjs);
    }(document, ‘script’, ‘facebook-jssdk’));</script>

    2-Change the /en_US/ to whatever your language is ,, i changed it to arabic ar_AR

    you can also get the code from here
    https://developers.facebook.com/docs/plugins/comments/

    Language selection in the plugin settings are for the Facebook SDK call only. Usually when your problem occurs it is because of the SDK call happening again elsewhere via another plugin or theme, outputting US English as default.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not able to change language’ is closed to new replies.