Support » Plugin: Volunteer Sign Up Sheets » Not able to add new task

  • Resolved thedills

    (@thedills)


    First of all… thanks for such a useful plugin. I use the plugin for individuals to signup to pray for a weekend event. It’s a 72 hour prayer vigil where there are 144 – 30 minute slots to fill. When originally creating the signup sheet in only created 142 slots (tasks)… but need to add one slot at the beginning and one at the end. For some reason I’m not able to get those tasks added and saved. It lets me add them, but when I save the sheet they are not showing up.

    Is there something that would cause a problem when trying to add task to a sheet that already has filled spots? Any thoughts or suggestions would be appreciated.

    https://wordpress.org/plugins/pta-volunteer-sign-up-sheets/

Viewing 16 replies (of 16 total)
  • Plugin Author DBAR Productions

    (@dbar-productions)

    OK… I have solved this, and, as expected, it is a server configuration issue, and NOT a plugin issue.

    I was just guessing the wrong server configuration issue. By default, PHP has its max_input_vars setting to 1000.

    I found this because I could see with my debugger that the post data was getting truncated, and when I put some code in to try to kill WP before it tried to process the post, I briefly saw an error message saying max_input_vars value of 1000 exceeded (there are also hidden inputs for each task row to identify which task_id in the database it is, so the number of input vars adds up fast).

    So, if you want to have a large number of tasks on any type of sheet, and you are exceeding the number of input vars, you need to update the max_input_vars setting in your php.ini file on your server (it’s not a WordPress file). I updated mine to 3000 on my XAMPP development server, and then I was able to add more tasks.

    Talk to your hosting company if you don’t know how to update your server’s php.ini file (or if you are on shared hosting with one php.ini that serves all sites). You’ll probably need to restart Apache also for the change to take effect.

    No plugin update/fix required. Update your php.ini, or split out your tasks to multiple sheets.

Viewing 16 replies (of 16 total)
  • The topic ‘Not able to add new task’ is closed to new replies.