Support » Fixing WordPress » not able to add favicon in xammp lite localhost test site

  • Please help me discern if it is me or the fact that a favicon on a “localhost” (home hard drive) will not allow a favicon. I think I put all the relative info below and all the solutions I’ve tried. Please be nice, this is my first thread (asking for help).

    Problem: favicon not showing up on a “localhost/wordpress” install. We are completely testing our site of of 2 different computers on 2 different hard drives before we upload and go live. Everything (plugins, test posts, test comments,etc.), works etcept, adding a favicon.

    Solutions tried: <link rel=”shortcut icon” href=”<?php bloginfo(‘template_directory’); ?>/favicon.ico” />

    yes I tried it this way also <link rel=”shortcut icon” href=”” type=”image/x-icon” />

    Yes it was a real favicon.ico sized 16×16 pxl
    my login is http://localhost/wordpress

    I tried every folder that had images and the non-image folders too: see below
    I tried all the favicon plugins such as, Admin Favicon, Blog Icons, Extended Options and others
    I tried it in xampp which is installed working fine on both computers (vista) wp- v2.6.3
    I tried the httdocs, wordpress file, wp-content, wp-admin, uploads, wp-includes, name the spot I’ve tried them all, obviously one at a time.
    cache clearing everytime, system reboots
    I read all 158 posts on the wp forum on favicons and all the favicon related docs and cut and pasted every possible code from everyones comments…nada.
    Instead of an http:/ our address to upload would look more like this :

    yes the right code was cut and pasted in the header.php below <head> in the theme editor.
    We are using the “Light” theme.
    yes I have write permissions php changes do occur in code thru the editor for everything we have done to all other parts of the theme/blog

    I am guessing that my problem is there is no traditional “root directory” like on a server and using “xampp lite” must be missing something or conflicting with the usual fixes. I’m having a little bit of the same problem with Post Avatar Plugin showing up when published, preview works, file is where it should be but doesn’t work. I am fairly sure that everything else works “offline” and is testing well, we just have dozens of hours in trying to make this “favicon” work and it occurred to me that maybe not all plugins or normal functions work outside of a normal server.

    Any help would be appreciated, you are the pro’s and I am the dreaded newb! Gasp, I said it! Had I not tried every forum (all 158 threads on favicon) , doc, combo and file/location I would not be writing. I’m really hoping that you’re going to tell me the xammp lite with a local host situation just does not have the complete programming to do the favicon but that we’ll be fine once we go to the real server/.com version.

    Thank you for your help and time,


Viewing 3 replies - 1 through 3 (of 3 total)
  • Just go and search for “maxblogpress favicon” in google and that is the only plugin yot want.Hope it helps.

    Hi sparun,

    Thank you for the suggestion but it requires a subscription which we are not up for nor do we have the expertise to pick apart the code to exclude the “required subscription”. We have tried all the other plugins, but this is an offline application. Maxblog press from what we can tell will not work any better than any of the other favicon programs and requires a subscription we don’t want any part of. We need some thing that will work “offline” on localhost.

    Thank you for the suggestion,


    The subscription is not for the plugin and it is only for the plugin author newsletter.Only one time you have to subscribe to activate the plugin and then you can unsubscribe from that mailing list.The plugin wont be affected.
    Or you can search this issue in this support forum to know what code to change to bypass registration.Hope that helps.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘not able to add favicon in xammp lite localhost test site’ is closed to new replies.