Support » Fixing WordPress » Not a valid XML file? What happened?

  • I am trying to add a Feedburner RSS button to my blog but when I input my web site name at Feedburner the response I receive is:

    The URL does not appear to reference a valid XML file. We encountered the following problem: Unknown feed format encountered (The root element is [Element: <html [Namespace: http://www.w3.org/1999/xhtml%5D/>%5D)

    I am a newbie just started with WP a few days ago, so, I really don’t know what this means or how to fix it.

    Any help and suggestions would be greatly appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi – It will help to see what your feeds look like. Do a browser View Source on your homepage. You should see a line or several lines in the head section (near the top) that relate to RSS

    Something like

    <link rel="alternate" type="application/rss+xml" title="My Title" href="http://www.mydomain.com/wordpress/feed" />

    Copy them, and paste them into a reply to this message. Use your mouse to highlight what you pasted in, then press the Code button, which prevents the forum software from mangling your code. Then click Post.

    Thank you stvwlf!

    After posting my question to this forum, I went ahead and posted a post and a page to my blog and they both took, and then I saw the RSS feed button appear…the problem sorted itself out once I posted my first post.

    Thank you again for your suggestion and for taking the time to help.

    <link rel=”alternate” type=”application/rss+xml” title=”Get Financial Help RSS Feed” href=”http://get-financial-help.org/feed/” />
    `

    <link rel="alternate" type="application/rss+xml" title="Get Financial Help RSS Feed" href="http://get-financial-help.org/feed/" />

    I removed the white space from a couple of my phps and it’s now working,

    Jane

    <link rel="alternate" type="application/rss+xml" title="Hollywood Buzz RSS Feed" href="http://feeds.feedburner.com/Hollywood-Buzz" />

    @kawauso – Hi!

    I did what stvwlf advised in his post above, but it made no difference 🙁

    I’m a complete non tech guy so not sure what’s going wrong.

    I still get this error :The URL does not appear to reference a valid XML file. We encountered the following problem: Error on line 53: The element type “description” must be terminated by the matching end-tag “</description>”.”

    Can anyone help me out please?

    audrey123

    (@audrey123)

    I am having trouble installing feedburner and am running into the same problem. I don’t know what my feed is, and have tried to look it up on the view source. I don’t know too much about this, but have been trying to figure it out for months and have been unsuccessful. Please help!! My website is: botanicafloraldesigns.com and my blog is at botanicafloraldesigns.com/blog. Thank you in advance!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Not a valid XML file? What happened?’ is closed to new replies.