Support » Plugin: Web Stories » Not a valid Web Story

  • Resolved clickrmedia

    (@clickrmedia)


    Hi,

    We created this page using Web Stories Plugin, and upon testing on the amp tool we see this result
    “Not a valid Web Story
    Invalid Web Stories will not have AMP-specific features in Google Search results”

    It has validation issues
    “The mandatory text inside tag ‘script amp-onerror’ is missing or incorrect.”

    Amp test link here
    https://search.google.com/test/amp?id=XpF8uisjIYmrxAEPmKvGdA

    Can you help us figure this out?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 12 replies - 16 through 27 (of 27 total)
  • Initial validation in progress…thank you! Looking forward to seeing the fix.

    Plugin Author Pascal Birchler

    (@swissspidy)

    @thehangrychickpea Looking at your most recent stories, there seem to be lots of videos with missing poster images, which will cause validation issues. I recommend adding any missing poster images & create a separate support thread here if you encounter any problems.

    Thanks Paschal – I’m not sure why there are missing poster images. I upload my one poster image with the 3×4 ratio as recommended, but my checklist still says I need one for each page.

    When I upload my videos, they don’t show an image, it’s gray until I press play. This issue just started when I created my last two web stories – could that be the issue?

    Not sure how to fix 🙁

    Vladi

    (@loveinlions)

    Hi @thehangrychickpea Re: posters, I had the same issue with another food blog, and what fixed it for me is uploading a poster that is exactly 640×853 pixels in size. Give it a try.

    Plugin Author Pascal Birchler

    (@swissspidy)

    @thehangrychickpea I was referring to video posters, not the story poster image. The story poster looks fine.

    You can set the video posters under the “Accessibility” tab:

    The editor tries to add those automatically, but it might not always work.

    Adding a video poster will fix those gray rectangles you see.

    Thanks Paschal. It’s quite cumbersome to add a poster image for each page in this way – do you know why it isn’t adding automatically?

    As a content creator, making these stories is already a ton of extra work, this might be the straw the breaks the camel’s back in terms of things that should be automated but aren’t (also on that list are captions that already exist in the videos I’m uploading, having to resize a poster image specifically for Web Stories).

    Plugin Author Pascal Birchler

    (@swissspidy)

    I totally understand that! This is why we have added this automation in the first place and are constantly improving it. But sometimes it might take too long and the operation is cancelled, or perhaps there’s an error on the server. There could be many reasons.

    If you’d like to open a new support topic and share some information about your setup, we’re happy to assist and find the root cause.

    In the meantime, another workaround is to remove the video from the story and then simply add it back. This should re-trigger the poster generation.

    Allowing you to resize/crop the story poster image upon upload and making it easier to provide captions are also on our roadmap.

    If you don’t mind opening a new topic, I’d also like to learn more about what you mean by “captions that already exist in the videos”.

    Hi I Created a Web story couple of days ago. I created using the wordpress plugin , when i checked on search console it shows Invalid AMP story. can you please suggest what is the problem.

    this is my web story URL
    https://www.governmentkischeme.com/web-stories/52-international-film-festival-india/

    please suggest.

    Hi created a web story a couple of days ago and on search console it shows as invalid web story.

    https://www.governmentkischeme.com/web-stories/52-international-film-festival-india/

    Can you please look into it and suggest.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @keshbhatt If you’d like to open a new support topic we’d be happy to assist with your case individually. Thank you!

    Hi,

    We created this page using Web Stories Plugin, and upon testing on the amp tool we see this result
    “Web Story is invalid
    Invalid Web Stories will not have AMP-specific features in Google Search results”

    Issues
    The parent tag of tag ‘html’ must be ‘!doctype.
    A mandatory AMP HTML tag is missing from this document.

    Amp test link here
    https://search.google.com/test/amp
    Can you help us to figure this out?
    <p> by the i have tested plugin installation method but problem not solved</p>

    Thanks!

    The page I need help with: https://www.mycareertip.com/web-stories/how-to-buy-laptop/

    • This reply was modified 2 weeks, 4 days ago by sanchafle.
    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @sanchafle If you’d like to open a new support topic we’d be happy to assist with your case individually. Thank you!

Viewing 12 replies - 16 through 27 (of 27 total)
  • You must be logged in to reply to this topic.