Support » Plugin: Web Stories » Not a valid Web Story

  • Resolved clickrmedia

    (@clickrmedia)


    Hi,

    We created this page using Web Stories Plugin, and upon testing on the amp tool we see this result
    “Not a valid Web Story
    Invalid Web Stories will not have AMP-specific features in Google Search results”

    It has validation issues
    “The mandatory text inside tag ‘script amp-onerror’ is missing or incorrect.”

    Amp test link here
    https://search.google.com/test/amp?id=XpF8uisjIYmrxAEPmKvGdA

    Can you help us figure this out?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    Hi there,

    Thanks for reaching out! The offending piece in the source code is referring to Kinsta CDN. Do you have Kinsta CDN enabled on your site? If so, you might want to reach out to Kinsta to ensure their solution works with web stories, and temporarily disable that CDN for web stories.

    Thread Starter clickrmedia

    (@clickrmedia)

    Hi Pascal,

    Thank you for your reply!

    Yes we enable Kinsta CDN, we will try to reach out to Kinsta and try disable CDN for web stories.

    But do we know what could be wrong about the Kinsta CDN and why will the CDN cause AMP validation errors?

    Is it the case where we cannot refer to external resources?

    Let us know if you have more info, we greatly appreciate the support!

    Thanks!

    Plugin Author Pascal Birchler

    (@swissspidy)

    The issue is that their solution is inserting custom JavaScript, which is not allowed in AMP/Web Stories.

    Thread Starter clickrmedia

    (@clickrmedia)

    Thanks Pascal, we get it now we are checking with out hosting provider on this CDN issue

    Plugin Author Pascal Birchler

    (@swissspidy)

    Quick update, there is apparently also a recent change in the AMP validator that causes this issue. We’re now looking into how to best address it in this ticket.

    Vladi

    (@loveinlions)

    I confirm this issue coming up in Search Console @swissspidy

    Plugin Support Luckyna San

    (@luckynasan)

    Thank you, @loveinlions. We will follow up as soon as we have an update.

    indiatrotter

    (@indiatrotter)

    Hi,

    Even we are facing the same issue.
    My web stories were showing up in both search and discover for a couple of days…it was steadily increasing to more than a 600 in a day as we kept adding more. Suddenly it dropped to zero is 2 days.
    https://snipboard.io/mtPipb.jpg

    One such link is: https://indiatrotter.com/web-stories/lakshadweep-island-tours/

    When I test the link now, it shows it is no longer a valid AMP!
    I did not do any change that would cause the error “The mandatory text inside tag ‘script amp-onerror’ is missing or incorrect”
    Moreover, it looks more like a source-code issue and not something I would be able to work out at my end.

    Still…Is there anything we should do on our part to resolve it OR would you update the plugin to take care of it?

    Thank you for your help, in advance.

    indiatrotter

    (@indiatrotter)

    If you can please update the same in this forum as well as update the plugin to stop the sudden disruption.

    Plugin Support Luckyna San

    (@luckynasan)

    @loveinlions @clickrmedia As a temporary workaround, you can download and install this mini-plugin as a temporary workaround to the AMP-onerror issue.

    We appreciate your patience as we continue to work on a resolution.

    indiatrotter

    (@indiatrotter)

    Dear @luckynasan So, do you mean for wordpress, we download the zip (from your link https://gist.github.com/swissspidy/3d8503785ca452b82ad21e7c30bc1ac2) and upload to WP?
    Is there anything else we need to do in settings OR will things work just upon activation of the “mini plugin”?
    Thank you for your help!

    Regards,
    Amitava

    Plugin Support Luckyna San

    (@luckynasan)

    Hi there, @indiatrotter. You will just need to activate the plugin for the workaround to work.

    1 . Follow this link https://gist.github.com/swissspidy/3d8503785ca452b82ad21e7c30bc1ac2
    2. Click on Download zip
    3. Navigate to WordPress Plugins > Add new > Upload plugin > Choose file > upload the file you downloaded from GitHub above > Install Now.

    indiatrotter

    (@indiatrotter)

    HI @luckynasan …Thank you very much for your guidance. I did that.
    It worked!
    There was a cache issue initially.

    Thank you a lot for your help and response.

    arnaudbrunel

    (@arnaudbrunel)

    It seems to have fixed my issue for now. Will wait for the fix.

    Working for me as well. Thanks!

Viewing 15 replies - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.