WordPress.org

Support

Support » Plugins and Hacks » NextGEN Gallery - WordPress Gallery Plugin » [Resolved] [Not a valid template]

[Resolved] [Not a valid template]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi @ivank123,

    I had a similar issue this morning, solved by opening the problem gallery and clicking “Save Changes”. Hopefully this helps you as well.

    CORRECTION: Ran into the issue again this morning, noticed that my shortcode had converted to an image tag after a NextGEN update.

    Fixed it by deleting and inserting a new shortcode via the NextGEN button on the post editor screen.

    After updating WP and then upgrading NextGEN to version 2.0.14, I am still also experiencing the [Not a valid template] error. I tried resaving the galleries but it didn’t fix it. The shortcode’s are fine.

    I am using prettyphoto media along with this to open them in a lightbox. Not sure what to do but it’s broken many galleries on my site.

    Plugin Author photocrati

    @photocrati

    @ivank123 / @mr.stacking.kit – As @ebreuers succeeded with, did you try replacing the shortcode with an ATP generated gallery?

    If so, can you also check to see if you are using default permalinks and try these troubleshooting steps again with permalinks set to something other than the default?

    My shortcode was within a sidebar widget, not a post. Do the shortcodes no longer work?

    Plugin Author photocrati

    @photocrati

    What is the specific shortcode you are using and in what type of sidebar widget are you using it in?

    Also, I would suspect you are using the shortcode in a text widget, does your theme and/or another plugin add shortcode functionality to text widgets, if that is what you are using?

    I’m using it in a text widget, yes. This is the exact code I have been using:

    [album id=3 template=lightbox]

    I’m using it with prettyphoto media which creates the lightbox overlay for this.

    A stipulation of this plugin is that rel=”prettyPhoto[%GALLERY_NAME%]” needed to be added to NextGEN under Gallery > Options > Effects – select Custom and enter the rel=”prettyPhoto[%GALLERY_NAME%]” code.

    I don’t see the option for Custom under Lightbox Effects. Was this removed?

    Any update on this? Can you please just confirm whether or not the ability to enter Custom lightbox code was removed? It used to be found under Gallery > Options > Effects – Custom was in the dropdown. Thanks.

    This has just happened to me.

    I’ve updated the plugin to last version (2.0.30) few minutes ago, but this wasn’t the only think I made. I’ve changed the web folder in my hosting: from /myweb to /subdir/myweb and all was working but this plugin, the page shown “[Not a valid template]”.

    After search a while, I’ve reviewed the “Gallery settings” and I’ve observed that all templates were pointing to old path… I corrected the path to the new one and saved the settings, and all worked again.

    Hope this can help to someone.

    Plugin Author photocrati

    @photocrati

    @ponç J. – Thanks for the reminder on what to check for when migrating a site with NextGEN Gallery. We made sure to add it in our FAQ as well, here: http://wordpress.org/plugins/nextgen-gallery/faq/

    It’s the first question at the top of the list.

    Same problem. I resolved it by deleting the old generated code and insert the gallery from the designer. Now the code looks like this:

    <img class=”ngg_displayed_gallery mceItem” alt=”” src=”http://www.–.com/nextgen-attach_to_post/preview/id–327″ />

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] [Not a valid template]’ is closed to new replies.
Skip to toolbar