WordPress.org

Forums

[resolved] Not a PHP Programmer - wp-config script not working (8 posts)

  1. rhondarobbins
    Member
    Posted 5 years ago #

    I cannot seem to get my script to run. I get the following error after editing wp-config.php

    'Parse error: syntax error, unexpected T_STRING in /home/rhondaro/public_html/wp-config.php on line 3'

  2. rhondarobbins
    Member
    Posted 5 years ago #

    can someone help me by looking at my scripts? and telling me what I am missing?

  3. Kailash
    Member
    Posted 5 years ago #

    If you have edited your wp-config.php file manually then there is some code error near line 3. If you are not sure then just download the latest version of wordpress and compare your code from wp-config-sample.php with your config file.

    Kailash

  4. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 5 years ago #

    We can't view your PHP script. Don't paste it here unless you blank out your db connection details.

    First thing to check though - you haven't introduced any white space or line breaks to the beginning or end of the file? If so take it out.

  5. BYurick
    Member
    Posted 5 years ago #

    The top of the wp-config file is usually just a commented area. I bet you accidentally added a character in there.

  6. rhondarobbins
    Member
    Posted 5 years ago #

    I have compared my script numerous times with the sample wp-config.php. I can't see any problem.

    no space before the first <?php
    here is the script minus passwords. I will get new authentication keys if I can just get the script working

    ______________
    <?php
    define('DB_NAME', 'rhondaro')
    define('DB_USER', 'rhondaro')
    define('DB_PASSWORD', 'xxxxx')
    define('DB_HOST', 'localhost')
    define('DB_CHARSET', 'utf8')
    define('DB_COLLATE', '')
    define('AUTH_KEY', '0@srjA1<Nm|$8@ 2+j0-?ry?]DT3Q8@|7,-u;t-toNpu %m eG^X.(6_a$#tYC');

    define('SECURE_AUTH_KEY', 'jRL3-)2%3_D!uBhH)xTKmnP>i<QI&-L&/>q3%dui_Sjw.6ru4?)$CRt!orW-]s+`');

    define('LOGGED_IN_KEY', 'vgZ^$Ky/Emyq7ejc&oAB=$(xHI&2:ih.{sf)XLIo+@w:/t1>7VP<vwFph}PdG!bt');

    define('NONCE_KEY', 'Ivwg-M[@/QN|<V5rTiG#7)A%/_N@r,#b>>gZB&.p%1uVwGE o|)}5|SGYh7XQ8');

    $table_prefix = 'heatH2714cat^&';

    define ('WPLANG', '');

    define('WP_SITEURL', 'http://xxx.com/');
    ?>

  7. Kailash
    Member
    Posted 5 years ago #

    ; is missing from line 2. The code should be as follow:

    define('DB_NAME', 'rhondaro');
    define('DB_USER', 'rhondaro');
    define('DB_PASSWORD', 'xxxxx');
    define('DB_HOST', 'localhost');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    Kailash

  8. rhondarobbins
    Member
    Posted 5 years ago #

    Thanks. I have a new problem now.

    that nasty little

    ;

    caused some frustration

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags