WordPress.org

Support

Support » Plugins and Hacks » [Resolved] NoSpamNX 4.0.2 flagging all replies as spam!

[Resolved] NoSpamNX 4.0.2 flagging all replies as spam!

  • Running WordPress 3.1, Akismet 2.5.3, and NoSpamNX 4.0.2.

    My editor called me this yesterday telling me that one of our sites was having an issue, where a few comments were incorrectly flagged as spam. I thought it was because they were running 4.0.1, so I upgraded to 4.0.2. But I got a call this morning, telling me it happened with 5 more comments yesterday on that same site, and even flagging his own two replies!

    I tried this as well, and had the same issues. After I deactivated NoSpamNX, the problem immediately went away. Reactivated it, and the problem returned.

    I ended up downgrading to version 3.22 for the time being, and that has solved the problem. But I have 60+ heavy traffic sites running 4.0.2, so if there’s a problem I want to catch it before it causes a huge problem for us.

    Any help you could offer up would be greatly appreciated!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ok, I figured it out.. Two of our sites were affected, and they were ones that underwent domain name changes at some point. Apparently NoSpamNX stored the old URLs in the database, so every reply was failing the referrer check.

    I fixed it on my end, and everything works good now.

    Plugin Author kubi23

    @kubi23

    @cartman
    The error shouldn’t occur with the latest release. The Referer-Check was deleted completly in NoSpamNX 4.0.3.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] NoSpamNX 4.0.2 flagging all replies as spam!’ is closed to new replies.