WordPress.org

Forums

Smart Layers by AddThis
[resolved] None of them working (45 posts)

  1. leonardogsouza
    Member
    Posted 1 year ago #

    I have no idea why, but I have just activated the plugin and nothing shows up on my website... Follow, share, what's next... nothing.

    http://wordpress.org/plugins/addthis-smart-layers/

  2. ridgey28
    Member
    Posted 1 year ago #

    Same here. I deactivated the plugin and added the code to my functions.php as you would a manual website. Note if you already have a wp_footer add action already just add it into that.

    <?php add_action('wp_footer', 'add_this_smart');
    function add_this_smart(){?>
    <!--add code snippet here -->
    
    <?php }?>

    I also added the following to only show on single pages

    <?php if(is_single()){
    //add function here
    
    }?>

    I posted the full code on Pastebin

  3. leonardogsouza
    Member
    Posted 1 year ago #

    You mean the code that you get from their website? On what part of function.php did you put that in?

    I don't use addthis to anything else so I probably do not have a wp_footer add action.

  4. ridgey28
    Member
    Posted 1 year ago #

    Yes from here https://www.addthis.com/get/smart-layers
    Select A Website from the Platform section.

    I just placed it at the end of my functions.php. If not 100% sure, make a backup copy first and make sure there are no spaces after the opening and closing PHP tags as you will get a white screen.

  5. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @leonardogsouza & @ridgey28 Yes you can place it manually from the site. But if you use it through the plugin, it will be easier to manage and configure. I will be pleased to assist you to clear the issue with plugin. Can you share me your url so that I can have a look. Also, in the plugin, can you try saving the settings in AddThis Smart Layer plugin?

  6. ridgey28
    Member
    Posted 1 year ago #

    @ srijith.v

    I have removed the manual code and re-activated the plugin.

    http://www.worldoweb.co.uk/

    Thanks in advance

  7. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @ridgey28: I can see that the configuration code is not being pulled into the html. I assume this got something to do with the theme. Do you have a dev/test site where you can provide me access and see what's going wrong in backend? Or if you have the theme, you can send it to us as well. You can send it to srijith[AT]addthis.com

  8. leonardogsouza
    Member
    Posted 1 year ago #

    Hi srijith.v
    My url is http://www.zunkabitz.com
    I haven't put the code (like ridgey28 did) and the plugin is activated.
    I do not have a dev/test site... My theme is this one: http://mythemeshop.com/themes/playbook/

    Thanks!

  9. kamillesaabre
    Member
    Posted 1 year ago #

    I love the plugin. Thanks. But since I updated WP to 3.7.1 it stopped working, and I miss it badly. Nothing appears on my webpage. I am simple user and not so advanced with codeing. Can I have your help please?
    http://www.kamill.ee

  10. kamillesaabre
    Member
    Posted 1 year ago #

    sorry, the webpage is http://www.kamille.ee

  11. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @kamillesaabre: Sorry for the delay. We are still working on it as from outside, it all looks fine and the configuration is printed in the html as well. Please bear with us for a bit more time to resolve this.

    @leonardogsouza: Noted that the page rendering is stopped right before the configuration needed for the plugin is outputted into the page. I got the theme and will check it in our installation.

  12. leonardogsouza
    Member
    Posted 1 year ago #

    Great srijith.v, will wait for your feedback. Thanks!

  13. kamillesaabre
    Member
    Posted 1 year ago #

    Thanks

  14. orenbj
    Member
    Posted 1 year ago #

    Please update me as well! Thanks.
    http://www.louderspace.com

  15. leonardogsouza
    Member
    Posted 1 year ago #

    After the update today, is working!

    Just one question, how do I control what social media buttons will appear on the side (Share)?

  16. orenbj
    Member
    Posted 1 year ago #

    I updated, but they are still not showing up for my site.

  17. leonardogsouza
    Member
    Posted 1 year ago #

    Actually, they are showing, but the "Recommended for you" sometimes send to the wrong post and I can't control what buttons appear on the side (Follow). Disappointed...

  18. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @leonardogsouza: You can control Follow buttons from the plugin options, but not the order. Share buttons are selected and shown by AddThis server to maximize the interaction depending on the visitor.

    You can control all of this and handpick the buttons and order from "Custom API Configuration" button on top right of Smart Layer options page. This is an advanced option and you may refer our support page for customization documentation.

    Regarding recommended content being faulty, can you show me an example of that? We are eager to see what went wrong.

  19. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @orenbj Is the plugin currently active in your site? I can't see the needed script in your page source.

  20. kamillesaabre
    Member
    Posted 1 year ago #

    Thanks a lot. I love your plugin and it works fine now!
    Thanks for caring

  21. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @kamillesaabre Good to hear that!!

  22. leonardogsouza
    Member
    Posted 1 year ago #

    srijith.v

    I used the following code, and now it stopped working =/ what did I do wrong?

    {
    'theme' : 'transparent',
    'share' : {
    'position' : 'left',
    'services' : 'facebook, twitter, google_plusone,more',
    'postShareTitle' : 'Obrigado por compartilhar!',
    'postShareFollowMsg' : 'Siga o Zunkabitz',
    'postShareRecommendedMsg' : 'Continue lendo:'
    },
    'whatsnext : {
    'recommendedTitle' : 'Especialmente pra você',
    'shareMsg' : 'Compartilhe! [x]',
    'followMsg' : Siga o Zunkabitz [x]'
    },
    mobile : {
    'buttonBarPosition' : 'bottom',
    'buttonBarTheme' : 'transparent'
    }
    }

  23. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    Yes, the code had mismatch on ('). The corrected one is:

    {
    'theme' : 'transparent',
    'share' : {
    'position' : 'left',
    'services' : 'facebook, twitter, google_plusone,more',
    'postShareTitle' : 'Obrigado por compartilhar!',
    'postShareFollowMsg' : 'Siga o Zunkabitz',
    'postShareRecommendedMsg' : 'Continue lendo:'
    },
    'whatsnext' : {
    'recommendedTitle' : 'Especialmente pra você',
    'shareMsg' : 'Compartilhe! [x]',
    'followMsg' : 'Siga o Zunkabitz [x]'
    },
    mobile : {
    'buttonBarPosition' : 'bottom',
    'buttonBarTheme' : 'transparent'
    }
    }

    You missed it here:

    'whatsnext : {

    and here:

    'followMsg' : Siga o Zunkabitz [x]'
  24. leonardogsouza
    Member
    Posted 1 year ago #

    ops, sorry about the silly mistake.

    Please note this screenshot: http://img607.imageshack.us/img607/8104/zkh2.png

    1) Google+ is not showing up, why?

    2) Remember about the recommended content being faulty? You see, instead of sending to another post, it sends to "http://www.zunkabitz.com/page/3/#at_pco=smlwn-1.0&at_tot=1&at_ab=per-3&at_pos=0" (page 3)

    Thanks!

  25. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @leonardogsouza:

    1. There is a limitation in the services which you can use in the share layer due to design. For google plus, please try 'google_plusone_share'

    2. Recommended content is working and lead me into an article when tried. It depends on the user, but still can you tell me a page from where the layer was showing the wrong link?

  26. leonardogsouza
    Member
    Posted 1 year ago #

    Still no Google+ =/ Don't understand this limitation, I'm using only 4 buttons...

    Recommended content is fine... I didn't liked that showed a link to a page instead of a article, but it doesn't bother me.

  27. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @leonardogsouza: From your site's html source it looks like you have the non-custom api mode enabled. If you try this:

    {
    'theme' : 'transparent',
    'share' : {
    'position' : 'left',
    'services' : 'facebook, twitter, google_plusone_share, more',
    'postShareTitle' : 'Obrigado por compartilhar!',
    'postShareFollowMsg' : 'Siga o Zunkabitz',
    'postShareRecommendedMsg' : 'Continue lendo:'
    },
    'whatsnext' : {
    'recommendedTitle' : 'Especialmente pra você',
    'shareMsg' : 'Compartilhe! [x]',
    'followMsg' : 'Siga o Zunkabitz [x]'
    },
    mobile : {
    'buttonBarPosition' : 'bottom',
    'buttonBarTheme' : 'transparent'
    }
    }

    it should show the G+ sharing option as well.

    Design constraint: The third party buttons like G+ will not gel with the other buttons in share layer by it's design. That's the limitation, not the count of services.

  28. leonardogsouza
    Member
    Posted 1 year ago #

    It worked now! Thank you, thank you so much!

    Since you are being so helpful, I'll ask this: how do I fix the FOLLOW buttons?

    It is working now, I put the code:

    'follow' : {
    'services' : [
    {'service': 'facebook', 'id': 'zunkabitz'},
    {'service': 'twitter', 'id': 'zunkabitz'},
    {'service': 'google_follow', 'id': '+Zunkabitz'},
    {'service': 'youtube', 'id': 'zunkabitz'},
    {'service': 'instagram', 'id': 'zunkabitz'},
    {'service': 'rss', 'id': 'http://http://feeds.feedburner.com/Zunkabitz'}
    ]
    },

    but the problem is the position. It is on the top right and I'd like to fix this to closer to my logo..

  29. orenbj
    Member
    Posted 1 year ago #

    Hi @srijith.v,

    Thanks for taking the time to help, it is appreciated. I have installed version 1.0.5 of AddThis Smart Layers and activated it for my site.
    Are there any further steps I need to take to get it to appear?

    Thank you,
    Oren

    http://www.louderspace.com

  30. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @leonardogsouza: Happy to see that!!

    For follow styling, 'at4-follow' is the css class you need to look for. In your current theme, the following css will move it to bottom-right corner of your logo.

    .at4-follow {
    right: 500px;
    top: 200px;
    }

    Try adding it to your theme's css file.
    You may adjust the pixel value according to your liking.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Smart Layers by AddThis
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic