Support » Fixing WordPress » NONE of my images in posts are displaying, “empty alt attribute”message

  • I just left one example with the link above, but in EVERY single one of my posts (over 150+ posts!) NONE of my images are displaying. They display in the previews and in search results and in the header, but not in the actual post itself. When I go into the editor, there is an error message that says “This image has an empty alt attribute” and a broken image icon for every image. The only way I have been able to fix this is by reloading the image from my library again, but we are talking about HUNDREDS of images so I can’t simply re-upload every single image… Please help! This only just started happening a few days ago and I have the latest WordPress version with all plugins updated…

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I found 403 forbidden on your console. It might cause of any plugin specially security plugins. Try deactivating all the plugins and activate one by one and see if it’s solves your issue & find which plugin makes conflict.

    If it doesn’t solves your problem, try rename your .htaccess to .htaccess_old and reload your site. If it works then just save your existing permalink structure.

    There are lots to check around but I think that any one from the above will solve your problem.

    And I’ve tried to directly load one image from that article and got this:

    Access Denied
    You don’t have permission to access “http://media.licdn.com/dms/image/C4D12AQGtW_dPFQPKdw/article-inline_image-shrink_1500_2232/0?” on this server.

    Reference #18.9501655f.1556481913.dd4bc72

    Can you try to disable that Content Delivery Network and see what happens?

    Now I get this when I try to load an image directly:

    <?xml version="1.0" encoding="iso-8859-1"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
             "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
    	<head>
    		<title>403 - Forbidden</title>
    	</head>
    	<body>
    		<h1>403 - Forbidden</h1>
    	</body>
    </html>

    Hey Shihab and Sinip, I really appreciate the input. But I am pretty confused. Not sure what you mean by content delivery network, or why the images would be “forbidden.” I did a backup restore for my website, and it seemed to fix the problem but then it returned. I updated all my plugins and reinstalled the latest version of WordPress, and now I am confused…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘NONE of my images in posts are displaying, “empty alt attribute”message’ is closed to new replies.