Support » Plugin: Give - Donation Plugin and Fundraising Platform » Nonce verification has failed

  • Resolved me-me123

    (@me-me123-1)



    The script was working fine but I noticed that the donations stopped.. When I went to try it out myself after entering my info and clicking “Donate Now” I get an error that says: “Nonce verification has failed”

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi there,

    Thanks for contacting Give support.

    I’d like to check this out in depth. Please use the form here https://givewp.com/contact-us/ and select ” I am responding to your request to contact give” and mention this ticket, as well as a link to the site in question.

    Thanks!

    Hi,

    I am having the same issue. When submitting I get the error message: Nonce verification has failed.

    Is there a solution for this?

    Best rgards.

    Plugin Author Devin Walker

    (@dlocc)

    @joeri1977 – do you have any sort of caching plugin or security plugin that may be causing the issue? This is only the second report of this I’ve seen and I’d like to find out what’s causing your nonce verification to fail.

    Hi Devin – @dlocc,

    I have both running. WP Fastest Cache plugin and iThemes security pro. I think the problem is with the WP Fastest Cache plugin because when I clear the cache the error message is no more. I have now excluded the page with the donation form in the WP Fastest Cache settings so hopefully there error is no more. Only the page is now loading a little bit slower.

    Best regards.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Thanks for the info @joeri1977 — Does WP Fastest Cache have the ability to export your WP Fastest Cache settings? If so, I’d love to test that to see if I find a cause for this issue.

    Joeri

    (@joeri1977)

    @webdevmattcrom, there are no export option. I have very little settings turned on because I had some issues with other things. The only options that are checked are:

    • The Cache system
    • Gzip
    • Browser Caching

    That’s it! No minify or combining css or js.

    me-me123

    (@me-me123-1)

    WP fastest cache was the problem for me…. I disabled it and it works fine now. Sorry that I did not update…

    I have been experiencing the same problem and I have WP Fastest Cache and Cloudflare running.

    I have added the donation page to the ‘Exclude’ list in WP Fastest Cache settings and also set the cache to bypass as a page rule in Cloudflare which appears to have fixed the problem for now (or it might be because I have cleared the cache, will have to wait and see I guess).

    Strangely I have the same setup on another website and it works fine despite running WP Fastest Cache and Cloudflare too.

    Only problem, I have a donation form in the footer of every page so I would have to turn off the caching plugin completely to enable that to work.

    Any ideas @dlocc @webdevmattcrom @benmeredithgmailcom ?

    https://www.greyhoundtrustdunton.org.uk/ – this site has the nonce verification problem

    https://www.greyhoundtrusthallgreen.org.uk/ – this site, same setup, doesn’t have the problem (yet)

    • This reply was modified 6 months, 2 weeks ago by  defthaus.
    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @defthaus

    That error most likely is triggered by the way your server handles sessions. Here’s a few things to try:

    WordPress default sessions sometimes don’t work well with certain hosts. There’s two main ways to set your site to have more reliable sessions with Give:

    a. Set this in your wp-config.php file: define( 'GIVE_USE_PHP_SESSIONS' , false);

    b. Try using this free plugin which switches your site to use native PHP Sessions instead: https://wordpress.org/plugins/wp-native-php-sessions/

    Note that you should not do BOTH of those methods, just one then test, then the other (if necessary) then test).

    Let me know how that goes for you.

    One of the sites I have running Give on suddenly started generating this error.

    Thankful to find this thread and I tried this solution posted by Matt Cromwell:
    a. Set this in your wp-config.php file: define( ‘GIVE_USE_PHP_SESSIONS’ , false);

    And so far donations are going through again.

    I just don’t understand why the error suddenly started happening though, when it’s been running fine for about a year. No new plugins added recently. We may have lost a few donations as this happened in the middle of a series of events encouraging donations and the reports of errors started coming in. So just wondering as well for some of the other sites I have Give running on, what might have caused the error to start.

    Thank you!

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    HI there,

    The only explanation I would have for why that would happen suddenly is a change in your server environment in how it handles sessions. Naturally, if you didn’t make any plugins changes, Give would change either — it’s code, it doesn’t really think for itself (yet!). So something MUST have changed, and since this is related to how your site tracks visitor sessions my guess is something at the host level changed.

    I’d reach out to your host and inquire about that. Also potentially about how caching is handled.

    Keep me updated on what you find and I might have more insight. Thanks!

    I’m having same issue out of the blue. Started 4 days ago.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @killerbake — Would you mind starting a new thread? While it might sound like a similar issue, every site is unique and has unique challenges. When you start the new thread, please provide your System Info and step-by-step details of exactly the issue you are facing so we can understand exactly what is happening.

    Also, reference the solutions above as well and let us know if any of those gave you more insight at all.

    I am getting the same error Nonce verification has failed.I have updated my php version. I used the native php sessions plugin and I cached that page. I am still getting the error when I try to make a donation

    Also I have talked to Site Ground my host and they also have done everything they can with no fix. They tried all of the below and have reached the end of their ideas… Please help.

    I have reviewed the case and tried solving it by disabling and flushing all caches for the application, setting the permissions for the application, clearing all sessions and addind the suggested code (define( ‘GIVE_USE_PHP_SESSIONS’ , false);) to the wp-config.php file of the application as per the developer suggestion to no avail.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.