Support » Plugin: Rotating Tweets (Twitter widget and shortcode) » Non-working on old but supported WordPress 3.7.21

  • Plugin just cause 500 server error immediately after its activation in WordPress admin panel for WordPress 3.7.21. Yes, it’s an old version, but this plugin says it supports WordPress 3.2+, so… WordPress become active and working again only after renaming plugin’s folder “rotatingtweets” to “rotatingtweets1”.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Martin Tod

    (@mpntod)

    Thanks for this. I’ll try to debug it and see what the problem is.

    I’m not aware that I’ve required any post-3.2 functionality but will double check. What version of PHP are you running incidentally?

    If you want to try a version that worked with 3.7.21 at the time, try https://downloads.wordpress.org/plugin/rotatingtweets.1.6.6.zip which worked up to 3.8.

    Martin, thank you for your professional reply.
    I used PHP 5.2.17 when tested Rotating Tweets 1.9 on my WordPress 3.7.21. There was no requirements for version of PHP in readme.txt of RT plugin, only for version of WP.

    Also I’ve discovered publish.twitter.com which solved my needs completely, so now I completely useless for testing purposes of RT plugin, sorry about this.

    Plugin Author Martin Tod

    (@mpntod)

    Thanks for highlighting this!

    I’ve found the bug and fixed it.

    The plug-in was using a function that was introduced in version 4.0 without first checking that the function existed.

    Just updating the plug-in to solve the problem now.

    Plugin Author Martin Tod

    (@mpntod)

    If you get a chance to retry the plug-in and tell me whether it works for you, that would be great!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Non-working on old but supported WordPress 3.7.21’ is closed to new replies.