Support » Plugin: Gutenberg » non valid json response coming from two gutenberg blocks

  • Resolved audioboon

    (@audioboon)


    Hi,

    I’ve been struggling for few days to resolve the issue with “Updating failed. Non-valid JSON response message at the top of my page.

    The issue comes with the image block and the icon box block from Gutenberg. When I remove the blocks the issue is resolved. I’ve tried everything I found on the net: deactivating all the plugins, saving permalinks structure, modifying htaccess, whitelisting IPs and json paths…nothing seems to work. And what is worse, I do think that the page is updating, but the message is there.

    can anybody help?

    the issue is linked with the following path : /wp-json/wp/v2/pages/115%3F_locale=user and it gets 500 error code in the debug.

    thanks

    • This topic was modified 1 month ago by audioboon.
    • This topic was modified 1 month ago by audioboon.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support David Smith

    (@get_dave)

    Hi @audioboon,

    Sorry to hear you’ve been having trouble.

    It looks like you’ve taken some good debugging steps which is great.

    I looked at the code and I found the following string which appears to be similar to that which you mention:

    The response is not a valid JSON response.

    https://github.com/WordPress/gutenberg/blob/6b8ba0d8965a83eb15697526ba23f893956401b3/packages/api-fetch/src/utils/response.js#L36

    Is that what you are seeing? If so it’s part of the apiFetch package which underlies almost all the API requests made by Gutenberg to WP REST API endpoints. The response coming back is either invalid JSON or doesn’t contain a JSON property at all.

    Error code 500 indicates an Internal Server Error. Therefore it seems likely this is something server related.

    As much as it is a pain, have you tried using this website on a completely fresh server? If it works there then you know it’s something to do with your unique server configuration.

    You could do this locally using something like Local By Flywheel (other options are available) which uses some standard setups.

    Also please

    1. Install a fresh copy of WordPress.
    2. Deactivate all Plugins.

    …to see if that has any bearing.

    I look forward to hearing back from you.

    All the very best

    Plugin Support David Smith

    (@get_dave)

    It looks like you haven’t had time to respond here so I’m going to go ahead and close this one out.

    Many thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.