Support » Fixing WordPress » non-utf8 character encoding: posts ok, comments not

  • Resolved voivoed

    (@voivoed)


    Hi,

    I moved my blog from MT to WP and have some issues. The character encoding for the database is latin1 (ISO-8859-1) and the blog is written in Portuguese, which uses accented characters (like “á” or “ê”).

    I modified the character encoding in the blog settings (under settings/reading/encoding for pages and feeds) to “ISO-8859-1” and all the old posts appear fine. Any *new posts* that I create also appear fine.

    Comments, though, are being displayed in utf8. If I look in the database, they seem to have been saved in the wrong character encoding (when I change the character encoding in the browser to utf8, the posts display wrong but the comments then display ok). If I edit a comment using the dashboard, the edited comment is saved correctly and displays fine afterwards.

    How do I change the character encoding for the comments?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Did you try to switch to a different theme? Just temporarily, to test.

    This might help:
    http://codex.wordpress.org/Converting_Database_Character_Sets

    Basically, you want to convert the tables to all be in the same sets and such. Really, I’d try converting everything to UTF-8. Everything tends to work when you do that.

    Ok… I changed the setting in the blog (settings/reading/encoding for pages and feeds) to UTF-8 and now everything works, with the exception of the last few comments posted.

    I don’t understand why it should, being that the database tables are using latin1 as their character encoding and the old posts where entered like that.

    But it is working, so I guess this issue is solved… for now! Thanks everybody! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘non-utf8 character encoding: posts ok, comments not’ is closed to new replies.