Support » Plugin: Contact Form 7 » Non-Stop Spinning arrows on submit button click but email is successfully sent

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Try switching to the default theme and deactivating all other plugins.

    I have exactly the same situation:
    One form works, another not.

    After a lot of testing i found the difference in using Html-Content-Type for mail body or not. Disabling Html-Content-Type stopped spinning arrows after sending mail.

    I think there must be a bug in the Contact-Form code.
    One thing i found out:
    The following HTML code worked with Html-Content-Type-Body:

    ....
    <td colspan="3">
    <div style="margin-left: 2em;">IBAN: ....

    this worked not:

    ....
    <td colspan="3">
    <div style="margin-left: 2em;">
    IBAN: ....

    The only difference ist the linefeed after div-tag.

    Please fix the bug.

    Thanks a lot !

    @takayuki

    Sorry, but I can’t do that. I’ve worked before with Salient theme and Contact Form 7 and it always work fine. If I change the theme to the “default”, my WordPress website will be completely messed up.

    Plugin should work fine as it has been doing for years! Please…. help us! 🙁

    @ campermarkus

    Hi! Thanks for your comments but one thing I have to remark is that don’t have any HTML content type in mail body.

    Actually, didn’t understand very well what worked with you. Please, if you can give me more advise I will be very happy.

    Thanks a lot again!

    I have the same problem and i also can’t disable my plugins or
    change the them.

    However, on a test site, i disabled all plugin and changed to default
    theme and it still keeps spinning.
    Please help to fix.

    @melanimerlo
    Do you have activated “Use HTML content type” for Message Body ?

    In my case it’s not possible to send more than approximately 512 characters in Message body with “Use HTML content type” activated.

    Short html messages will be send without spinning arrows. Sending long messages the arrows keep spinning !?

    Can anybody confirm this ?

    Thanks

    After changing smtp server to gmail, sending of “long” mails is again possible !!!

    If the FROM field is:
    left blank
    Configuration Error: This field has syntax errors
    contains [your-name]
    Configuration Error: This field has syntax errors.
    contains [your-name][your-email]
    Configuration Error: This email address does not belong to the same domain as the site.

    All has to do with the Validator introduced in V4.4

    @kbsmayo: This is not your topic. If you require assistance then, as per the Forum Welcome, please post your own topic.

    @esmi. I don’t understand why I should have to do this. I am simply adding to this discussion which for some reason remains unresolved for many users.

    Surely my comments are constructive??

    @kbsmayo hi! Thanks for your comment. I am sure it is valuable. The thing here is that actually, the issue that we are reporting is different; it’s not a validation issue. The problem is still there and I really liked Contact Form 7 but had to SOLVE that and had to buy a licence of Gravity Forms because my client was pretty mad at me.

    Anywhay; hope plugin authors can solve this, some time…

    Thanks!

    Daniel

    (@ddumondgmailcom)

    I’m having the same problem… Some forms work, others don’t… Funny thing is, forms that were already finished and tested that worked, stopped working when I first noticed this problem with my latest form.

    For some reason this issue is marked as “resolved” when I see so confirmed solution.

    I feel like I’ve tried everything — I event went as far as removing all the content from the email templates (to send a blank email) to see if there was a conflict with formatting.

    It can’t be related to plugins or themes (in my case) as the forms stopped working midway through where nothing on that end was changed or added.

    Has anyone had any success with this?

    Thanks.
    Dan

    I am having the same issues…

    Rather annoying…

    I am using the following
    ‘Postman SMTP’, configured it to use Google’s SMTP servers.
    ‘Contact Form 7 MailChimp Extension’

    I have been using this for several years, always going back to my demo site that is configured and works, to copy the setting from, for consistency.

    Yet this time around… the spinning arrow is rather annoying. I had to pull the reCaptcha out of Contact Form 7 because it would “time out”.

    YET the
    – email is sent correctly
    – the ‘form’ correctly filled out to MailChimp

    For those who feel it’s necessary to give the SOP of “turn off plugins and use a default theme” This is the exact same theme and plugins used on my “demo site”…. and it works there.

    I would love to hear some good suggestions or tests to try.

    Thanx

    I had the same problem and resolved it by disabling the following plugin:

    “Contact Form 7 Email Validation”

    Hope that helps!

    @premierweb That makes absolutely no sense…. didn’t list that plugin as something I am using.

    I am still having this issue and would really like to get it resolved.

    If someone who has dealt with this before can lend an idea, I would like to hear about it, thanks!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Non-Stop Spinning arrows on submit button click but email is successfully sent’ is closed to new replies.