WordPress.org

Forums

[resolved] Non Static IP address problem (3 posts)

  1. Wanzibar
    Member
    Posted 2 years ago #

    I have a wordpress blog set up on an arch linux box on my home network. I have a domain forwarded to my external IP, which is then forwarded to my arch linux box by my router.

    Problem I'm running into is that my external ip isn't static and it changed when I reset my modem last week.

    I have used myphpadmin to change the database entry for my site url to the new external IP but I'm having trouble accessing my site form my local computer.
    Also from external networks my site shows up but I cant manually enter /wp-admin and have it do anything

    I dont know exactly what features this non-static has ruined but I can no longer login to my dashboard because /wp-admin either times out or simply returns a blank white page.

    What should I do to fix my site?

    [ Please do not bump, that's not permitted here. ]

  2. When you get home, try temporarily setting the WordPress Address (URL) and Site Address (URL) to the internal IP address. This is so you can at least get into the installation at home.

    http://codex.wordpress.org/Changing_The_Site_URL#Edit_functions.php

    Make sure you have a backup of your theme's functions.php file first.

    my dashboard because /wp-admin either times out or simply returns a blank white page

    It also could be a plugin/theme issue but try the above first.

    Once that's done:

    Problem I'm running into is that my external ip isn't static and it changed when I reset my modem last week.

    Does your cable router support DDNS? If it does then try creating a dynamic DNS entry and have your DNS entry point to that dynamic DNS name as a CNAME record.

    If the cable router does not offer that option, there is always the idea of running dyndns client on your Linux server.

    That's how I keep connecting to my Crash Test Dummy. My IP address at home changes all the time. ;)

  3. ngoguen
    Member
    Posted 2 years ago #

    Does your cable router support DDNS? If it does then try creating a dynamic DNS entry and have your DNS entry point to that dynamic DNS name as a CNAME record.

    If the cable router does not offer that option, there is always the idea of running dyndns client on your Linux server.

    No-IP.com is a great solution for free dynamic DNS. If we are not included in your router as an integrated DDNS provider, you can install our free Dynamic Update Client on your Linux server. Please let me know if you have any questions or need help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.