Support » Plugin: Quick Paypal Payments » non-numeric value encountered

  • Resolved Brandoney

    (@brandoney)


    I’m getting an error message on my website in quick paypal payments.

    Warning: A non-numeric value encountered in ..texasheroesfoundation.org wp-content plugins quick-paypal-payments/quick-paypal-payments.php on line 1658

    Was a resolution to this problem ever found?

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author aerin

    (@aerin)

    I don’t get this message when I view your site so it’s difficult to diagnose. I’ve looked at the plugin code but can’t see anything that would result in this message.

    However, the simplest way to clear the message is to disable the wordpress debugger.

    • This reply was modified 1 year, 3 months ago by  aerin.

    It seems to be an issue in php7.1 with
    $dompdf->render() (or ->stream()
    from this thread
    https://github.com/dompdf/dompdf/issues/1272

    I don’t understand it, but maybe it will help you.

    I fixed the issue by downgrading to php7.0. I don’t remember why I went to php7, but I hope it wasn’t something that needed 7.1.

    Thanks again for your help.

    Plugin Author aerin

    (@aerin)

    Can you try this version: http://quick-plugins.com/wp-content/uploads/quick-paypal-payments.zip

    I spent some time last night fixing some php warnings and it should solve the problem you encountered. I’ve tested on a site using PHP7.1 and all was OK>

    Hi there,

    I moved a site running this plugin to a new host on PHP 7.1 and I’m getting the same warning:

    PHP Warning: A non-numeric value encountered in /wp-content/plugins/quick-paypal-payments/quick-paypal-payments.php on line 1658

    Is the version suggested here above currently the latest one or is it a planned update?

    Thanks.

    Plugin Author aerin

    (@aerin)

    Hi John,
    The problem is I don’t know what to fix. Line 1658 is:

    $required = “.qpp-style”.$id.” input[type=text].required, .qpp-style”.$id.” textarea.required {border: “.$style[‘required-border’].”;}”;

    None of the variables in that line are supposed to be numeric so the warning makes no sense.

    If the warning told us what the errant variable was I could do some investigation.

    If I’m not wrong, at my installation of current version 5.5.2, line 1658 is this one:

    $handle = $style['slider-thickness'] + 1;

    Are we talking about the same file?

    Plugin Author aerin

    (@aerin)

    Interesting, that’s line 1683 for me. But no worries

    $style[‘slider-thickness’] is a numeric value. Add 1 to this and it’s still numeric which means $handle will be numeric.

    So I really don’t know what I need to fix.

    But try this. Go to the plugin editor and open quick-paypal-options.php. Go to line 205 and change

    ‘slider-thickness’ => ‘2’,

    to:

    ‘slider-thickness’ => 2,

    and see if it fixes the problem. Not sure it will but I’m clutching at straws here. When I enable debugging I don’t get this error message which is why I don’t know how to fix this bug.

    Just tried that but the issue is still the same.
    I cleared the error log, made the edit, saved and returned to the Dasboard – no new error.
    Went to frontend homepage, returned back to Dashboard and there was a single error line.
    Cleared the error.
    Went back to frontend and visited 2 pages this time (not where the plugin is running).
    Went back to Dashboard and got 2 new identical error lines with same reference 1658…

    That means that the error is generated every time any page of the site is loaded.

    I’m not a dev and I really can’t help better with this, sorry.

    John

    (@dsl225)

    For what is worth, I’m getting a similar message at another site that is NOT running this plugin and is on another server, but also with PHP 7.1:

    PHP Warning: A non-numeric value encountered in /wp-includes/functions.php on line 64

    Seems to be a general issue with PHP 7.1.

    Hi

    Getting this now too with the new update. PHP 7

    Warning: A non-numeric value encountered in /home/user/public_html/wp-content/plugins/quick-paypal-payments/quick-paypal-payments.php on line 1687

    • This reply was modified 1 year ago by  Phil Emery.
    • This reply was modified 1 year ago by  Phil Emery.
    Plugin Author aerin

    (@aerin)

    My line 1687 is:

    if ($style['corners'] == 'theme') $corners = '';

    Neither of those two variables are supposed to be numeric. So I’m not actually sure what the warning is suggesting.

    John

    (@dsl225)

    Hi guys, this problem seems to be solved since the latest update.

    At least, as far as I’m concerned, I don’t get this error anymore.

    Thanks for the update!

    I’m using QPP Version 5.6.4 with PHP 7.2 and see this warning in “error_log” once every few seconds:

    [05-Dec-2018 14:51:12 UTC] PHP Warning: A non-numeric value encountered in /home/rrcsadmin/public_html/wp-content/plugins/quick-paypal-payments/quick-paypal-payments.php on line 2138

    The code at this location is:

    $handle = $style['slider-thickness'] + 1;

    So I believe this is still a problem. I would suspect that $style[‘slider-thickness’] is null or a non-numeric value (perhaps stored in the database) and that is the source of the problem.

    • This reply was modified 4 months, 2 weeks ago by  Larry Daniele. Reason: Corrected "error" to "warning"
Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.