• Resolved istoka



    I have an issue with adding a non-necessary script for Google Analytics. Trying to store the script in the field returns an error :

    Uncaught TypeError: Cannot set property 'value' of null
        at cli_store_settings_btn_click (cookie-law-info-admin.js:265)
        at HTMLInputElement.onclick (edit.php?post_type=cookielawinfo&page=cookie-law-info-thirdparty:446)

    also 404

    POST http://domain.com/wp-admin/edit.php?post_type=cookielawinfo&page=cookie-law-info-thirdparty 404 (Not Found)

    I have the plugin installed on another domain – I’ve set it up a month ago and everything was fine. Trying to re-save the analytics code, however, returns the same error.

    Any ideas on the issue? Thanks much in advance!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Another one here 🙂

    I just want to report that I had Wordfence firewall enabled, but disabling it didn’t help with the issue.

    Also, in the POST part, I did not receive a 404 but a connection reset error.

    Installed it today, fresh of the shelf.

    Plugin Author webtoffee


    Hi @kokan87, @istoka

    As we are unable to replicate the error in our test sites,we request you to submit a support ticket here and share site details so that we can check.

    Ok, I created a clone of the site on another server that uses cPanel and managed to save it without a problem, could be server related issue.
    @istoka is your WebHost by any chance using Plesk?

    Thread Starter istoka


    @kokan87 it is using cPanel. Both (the working and the non-working one) are using cPanel.

    The weird thing is I can save regular text, but I can’t save <script></script> scripts.

    @webtoffee does the plugin require some special folder permissions? I got 403 on a test site, while trying to save scripts.

    Plugin Author webtoffee


    Hi @istoka, @kokan87,

    We have fixed the issue in the latest version. Please update and let us know if anything.

    Updated the plugin, on first save I was asked to whitelist action by Wordfence security, refreshed page, saved again and it worked.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Non-necessary script not stored’ is closed to new replies.