Support » Plugin: Memphis Documents Library » Non-members cannot download files

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author bhaldie

    (@bhaldie)

    What settings are you using, it would help if I knew what settings you have turn on and or off. Looking at my test site with default settings I am not getting any issues.

    Some key setting would be “Downloadable by Non Members” in the file manager and also in settings hide file from non members.

    Cameron Barrett

    (@cameronbarrett)

    Here is a screenshot of the Settings.

    https://www.dropbox.com/s/ex95a3nwrsvwrqn/Screen-Shot-2016-11-23-at-11.47.25-AM.png?dl=0

    Here is a Page containing a Mdocs library that has files that can be downloaded by non-logged-in users and files that can’t.

    http://www.nps.k12.nj.us/advisory-board/sab-monthly-reports/2016-2017/

    See October and November reports cannot be downloaded but August and September can for users not logged in.

    Plugin Author bhaldie

    (@bhaldie)

    So I have found the bug, it has to do with the setting “Show upload social” under the Display File Properties settings.

    Will fix the issue moving forward, but for now if you check the “Show upload social” checkbox the file will be downloadable for non members.

    Thanks for the report I will have a fix asap 🙂

    Cameron Barrett

    (@cameronbarrett)

    Checking “Show upload social” checkbox has no effect. No change in behavior for not-logged in users. They still cannot download files.

    Cleared browser and server caches, also.

    Plugin Author bhaldie

    (@bhaldie)

    you will have to manually change the already uploaded files.

    But new file uploads should have no trouble.

    • This reply was modified 6 months ago by bhaldie.
    Cameron Barrett

    (@cameronbarrett)

    Ah yes, I see. Checking that box then gives me checkbox options for each file when I click “Manage file”. Thankfully, “Batch Edit” works flawlessly so I can check these checkboxes for an entire set of files in a Mdocs folder at once.

    Plugin Author bhaldie

    (@bhaldie)

    Yeah, that should do the trick. And as I said before I will fix the issue asap and have it in the next version 🙂

    Thanks again for the report.

    Plugin Author bhaldie

    (@bhaldie)

    This issue should now be fixed in version 3.6.11

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.