Support » Plugin: WP Super Cache » Non-existent changeset UUID / Theme Not Accessible anymore!

  • Resolved Joe76000

    (@joe76000)


    Hello Folks,

    – My Web site: https://www.linuxrouen.fr/wp/
    – WordPress web address (URL): https://www.linuxrouen.fr/wp
    – Web site address (URL): https://www.linuxrouen.fr/wp
    – I have moved to HTTPS one year ago!
    – Theme: Smartline Lite 1.4.4 (ThemeZee) updated few months ago
    – WordPress: 4.9.1–fr_FR in FRENCH updated on Nov. 11th 2017
    – PHP 5.6.30, MySQL 5.5.55-0+deb7u1-log – Linux

    PS: This message is published on the forums of WordPress, iThemes Security and WP Super Cache as they are potentially involved into my problem resolution.

    No change was done on my site before here under problem occurred, expect the updates of WordPress and the already installed plug-ins (a small dozen). All are in their latest versions.

    Since few weeks I have a new and very annoying behavior in the Administration (Dashboard) part of my WordPress site.

    PROBLEM DESCRIPTION
    1. When I’m trying to go to “Apparence – Personnaliser (Appearance – Customize) I’m getting at the left the usual entries, but the rest of the screen is blank and it’s flashing twice very quickly (less than 0.1 second) the following message “Non-existent changeset UUID.” and then a little still windows display something like “Your session has expired. Please reconnect you for restarting at the last visited page”. So, I enter my IDs, and then I’m going back to the above loop with the same message “Non-existent changeset UUID.”. And back again, “Please reconnect you…”. And so on, and so on…
    To go back to the Dashboard, because I’m still connected!, either I click on the cross of the Customize windows or the back button of my browser.

    2. When I want to disconnect completely from the Dashboard, I’m now getting a new message “You are disconnecting from your Web site. Do you really want to disconnect?”. Yes of course, what an “idiot” question!

    3. Few weeks ago when everything was working well, when connected to the Dashboard, opening the Welcome page or an other page-article of my site, it was displaying the top bar of the Dashboard, which is anymore the case.

    PROBLEM ANALYSIS
    1.I have red a lot of things on several forums including this one, but nothing was really matching with my current problem.

    2. So, as usual I started to investigate my dozen of plug-ins used since 2 to 3 years. And after few days of heavy testing I found that both iThemes Security 6.7.0 (iThemes Media LLC) and WP Super Cache 1.5.9 (Automattic) were some way or an other the potential culprits, perhaps with WordPress 4.9.1 (Automattic) too.

    3. For the time being the workaround I have found for being able to access successfully to Dashboard -> Appearance -> Customize is:
    – WP Super Cache -> Easy – No caching / Advanced – “No” Enable caching
    – iThemes Security -> WP Modifications -> File Editor – Deactivate file editor

    4. But, as I need WP Super Cache on my site, before leaving WP Dashboard, I do need to reactivate it:
    – WP Super Cache -> Easy – caching activated / Advanced – “Yes” Enable caching

    5. But when back to WP Dashboard I need to apply again and again my workaround:
    – WP Super Cache -> Easy – No caching / Advance – “No” Enable caching
    – iThemes Security -> WP Modifications -> File Editor – Deactivate/Activate (depending of its previous state) file editor
    -And of course before closing the Dashboard:
    WP Super Cache -> Easy – caching activated / Advance – “Yes” Enable caching

    ANY SOLUTION(S) ?
    As you can read above, it’s more than annoying to loose his time with this tricky endless game!
    All answers and suggestions are the welcome.

    Thank you. Joe

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Joe76000

    (@joe76000)

    Hello,

    FYI, the same subject has been closed in “WordPress Support – Fixing WordPress” and redirected here by a forum moderator.

    Concerning iThemes Security, there is no dedicated forum for their plug-in, only for the Pro version.

    Cheers.

    Joe76000

    (@joe76000)

    Well, I found this: Customize Changesets Technical Design Decisions as of 2016-11-15, but it’s too technical for me.
    It’s looking like being Chinese or something similar!

    Update of my current investigations…

    It seems there are two possible root causes:
    1. It is caused by HSTS (HTTP Strict Transport Security) with sub-domains such as WWW turned on and having two seperate URLs for WordPress web address (URL) and Web site address (URL).
    But in my case, both are the same since a while! See my 1st post.

    2. It is simply having the plug-in WP Super Cache active. Deactivate it to view preview.
    Yes, it working in my case, but it’s really painful to be obliged to do that each time you create and/or edit a page, an article, and so on. In add, WPSC needs to be rebuilt each time and it’s taking a while.

    So, as this problem now exist for more than one year based on my Web survey and as WP Super Cache seems not reactive on this subject, I will go fishing for an other cache plug-in, hopping not to face to the same annoying problem…

    I have the same problem on my website , I have tried to see several manuals and I can’t find the solution.

    • This reply was modified 2 weeks, 5 days ago by  shalirey.

    So, let’s continue this topic and see which alternatives we have for replacing WP Super Cache.

    1. How to uninstall WP Super Cache Plug-in?
    If you suspect that WP Super Cache is causing issues on your website, like here with “Non-existent changeset UUID / Theme Not Accessible anymore!”, and if you would like to install another WordPress caching plug-in, it is very important to make sure that you uninstall it the right way. See the WPSC instructions on How to uninstall WP Super Cache. Otherwise, it could haunt you and the load time performance of your site!

    2. How to select the best dedicated Caching plug-in for you and your WordPress blog/site?
    The first step is to identify what you expect from your caching plug-in and create criteria accordingly. Criteria could include:
    – Cost: from free to a few hundred dollars-euros/year.
    – Complexity and intuitiveness: based on your own experience with WordPress and its plug-ins.
    – Power and functionality: extra features such as integration with CDN (content delivery networks), GZIP compression, and minification. These all enable your site to run even faster but are really only necessary for large sites.
    – Support: Some plug-ins have support lines, forums, documentation. Others may have very little support or even none at all. How much support do you feel comfortable having?

    3. So, now that we have our basic criteria sorted out, let’s have a look at some of the most popular caching plug-ins, accordingly to market survey and number of active installations:
    WP Super Cache (by Automattic): Free, the one we want to replace after testing
    W3 Total Cache (by Frederick Townes): Free
    WP Fastest Cache (by Emre Vona): Free
    Comet Cache (by WebSharks, Inc.): Free + Premium
    Cache Enabler – WordPress Cache (by KeyCDN): Free
    WP Rocket (by WP Rocket): only Premium
    Read their documentations to see how they could meet your criteria.

    4. Next steps
    Choose the right plug-in for your site and test it live…

    So, if in your WordPress 4.9.x:
    – your Web site = WordPress web address (URL), and
    – you use WP Super Cache plug-in 1.5.9 (latest version to date),
    then you have to do the following for avoiding the “Non-existent changeset UUID” error messages and permuting again the access to the Customizer.

    => WP Dashboard -> Settings -> WP Super Cache -> WP Super Cache Settings -> Advanced tab -> Miscellaneous -> UNCHECK the little box in front of “Make known users anonymous so they’re served supercached static files.” because if CHECKED it’s FULLY INCOMPATIBLE with at least WP 4.9.x.

    Even Automattic, the main developers of WP Super Cache awa WordPress, were incapable to figure out this bug in their plug-in!

    PLEASE WP Super Cache’s developers, FIX this bug in your plug-in. Thanks.

    Cheers,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.