Support » Plugin: Redirection » Non-English urls no longer redirect

  • Resolved physixfan

    (@physixfan)


    Previously non-English urls redirect fine. But in the latest version (maybe as well as a few versions ago), they no longer redirect and return 404 errors.

    For example: https://www.uscreditcardguide.com/长期持有信用卡推荐/
    I have this setting for this url: redirect /%E9%95%BF%E6%9C%9F%E6%8C%81%E6%9C%89%E4%BF%A1%E7%94%A8%E5%8D%A1%E6%8E%A8%E8%8D%90/ to /best-credit-cards-to-keep/ . But it no longer works.

    Please make changes to make non-English redirections to work again, thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author John Godley

    (@johnny5)

    I’m not able to reproduce a problem when I use that source.

    Do you know what character set your database is using?

    physixfan

    (@physixfan)

    https://www.urlencoder.org This website can translate non-English urls. I think the default setting (UTF-8) is the one we currently use.

    Note: https://www.uscreditcardguide.com/%E9%95%BF%E6%9C%9F%E6%8C%81%E6%9C%89%E4%BF%A1%E7%94%A8%E5%8D%A1%E6%8E%A8%E8%8D%90/ is equivalent to https://www.uscreditcardguide.com/长期持有信用卡推荐/ in all modern browsers.

    Plugin Author John Godley

    (@johnny5)

    Sure, I understand about URL encoding, and your URL above works fine on my site. Maybe if you export your redirect as JSON and send it to me then I can take a closer look?

    physixfan

    (@physixfan)

    Sure! Can you give an email address? I think it’s better not to paste the JSON file in a public forum…

    Plugin Author John Godley

    (@johnny5)

    It’s available from the plugin support page or https://redirection.me/contact/

    physixfan

    (@physixfan)

    Sent, thanks!

    I noticed that all recent redirections automatically used another character set somehow. An example:

    {
    “id”: 6568,
    “url”: “/\u5e38\u89c1\u65e0\u5e74\u8d39\u4fe1\u7528\u5361\u5217\u8868/”,
    “match_url”: “regex”,
    “match_data”: {
    “source”: {
    “flag_query”: “exact”,
    “flag_case”: false,
    “flag_trailing”: false,
    “flag_regex”: true
    }
    },
    “action_code”: 301,
    “action_type”: “url”,
    “action_data”: {
    “url”: “/list-of-no-annual-fee-credit-cards/”
    },
    “match_type”: “url”,
    “title”: “”,
    “hits”: 42,
    “regex”: true,
    “group_id”: 2,
    “position”: 951,
    “last_access”: “2019-06-19”,
    “enabled”: true
    }

    Maybe this is the reason why it stopped working. I am not sure what caused this change…

    Newly added redirections work fine now. But previous ones still don’t work properly. See the link in my original post for example.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.