Support » Plugin: Fast Secure Contact Form » non English languages not enabled?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Mike Challis

    (@mikechallis)

    Sometimes a language file will be older than the current version of Fast Secure Contact Form for WordPress. In that case there may be some text that appears in English instead of the set language.

    Version 4.xx needs all the language files updated.

    This help page explains how to take an existing language file and update it.
    http://www.fastsecurecontactform.com/how-to-update-translation

    If you are able to update ta language file, please contact me so I can include it.

    Hi Mike,
    I’ve done everything you described to update the translation (in my case to German)…but it does not work, it’s still in English. I even uninstalled the plugin and reinstalled it – no effect.
    What could I do now?
    Thanks for your help…

    Mike, you wrote:

    In that case there may be some text that appears in English

    In fact it’s not just “some text”, it’s any text. Nothing is translated, as if this version didn’t take the language files into account.

    Plugin Author Mike Challis

    (@mikechallis)

    I will check if there is a technical problem and report back

    Plugin Author Mike Challis

    (@mikechallis)

    Indeed this is broken in 4.0.6, will be fixed in 4.0.7

    Thank you

    Hi Mike,
    Translation is broken for French language.
    Some fields are not corrects, for instance “First Name, Last Name or Re-enter Email” are still in english.
    Was the same in 3.x versions. I was obliged to translate every time I updated.
    I thought with this new version the problem would be fixed, but it isn’t.
    I sent you few monthes ago a correct translation for French, but you didn’t take care and didn’t include it.
    So will we be always forced to re-code at every update ? Or will you fix this point ?
    Regards.

    Plugin Author Mike Challis

    (@mikechallis)

    Version 4.xx needs all the language files updated.

    This help page explains how to take an existing language file and update it.
    http://www.fastsecurecontactform.com/how-to-update-translation

    If you are able to update a language file, please contact me so I can include it.

    Hi Mike,
    What I mean is when is selected to display both (First Name & Last Name), translation doesn’t work…
    I check the sourcecode but didn’t found why…
    (includes/class-fscf-display.php)
    Regards.

    $tab_names = array(
    __(‘Basic Settings’, ‘si-contact-form’),
    __(‘Fields’, ‘si-contact-form’),
    __(‘Styles’, ‘si-contact-form’),
    __(‘Labels’, ‘si-contact-form’),
    __(‘Security’, ‘si-contact-form’),
    __(‘Advanced’, ‘si-contact-form’),
    __(‘Scheduling’, ‘si-contact-form’),
    __(‘Tools’, ‘si-contact-form’),
    __(‘Newsletter’, ‘si-contact-form’),
    );
    Every tab is translated, except Fields… Why ????

    Hi Mike,
    I’ve found the reason of translation problems: poedit declared as “fuzzy” some entries and so they didn’t display. Changed for “validated” translation and everything is OK.
    I have made a very advanced translation for French language.
    I’m sorry to tell you that, but your actual one is so bad, with numerous errors. Done by Canadians I guess. lol
    Are you interested by my version, in which all essentials terms are translated (more than 75%).
    If you want it to integrate in next FSCF version, send me an email address where I can send you the files for checking.
    You will be able to look at the end of .po file: some translation are done for missing terms in the core markup of FSCF (Add New Field, Show Details, General Field Settings…). It could help you to improve it.
    I’m so tired to rewrite it at every update…
    Regards.

    Plugin Author Mike Challis

    (@mikechallis)

    Yes i will add the translation.
    Please contact me here and I will reply with my address http://www.fastsecurecontactform.com/contact

    Plugin Author Mike Challis

    (@mikechallis)

    The email address you contacted me with did not work

    Has anyone solved this issue yet? I have a 5-language site. FSCF 3.x.x automagically translated my forms (“name”, “email”, “message”, “required field” etc), but since upgrading to 4.x.x they’re all in English and no matter how many times I try this, it still doesn’t work.

    Anyone?

    Plugin Author Mike Challis

    (@mikechallis)

    ninedoor:
    With version 3.1.6.1 and up, including 4.xx versions, HTML is no longer allowed in field labels, versions older than 3.1.6.1 could have HTML.
    This is why the multi-language translation method you used no longer works with qtranslate.
    http://www.fastsecurecontactform.com/how-to-translate-extra-fields

    Here is the solution:
    There is another plugin called gTranslate, I use it on my site site, it does automatic translations by google translate. There is no contact form settings adjustment needed.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘non English languages not enabled?’ is closed to new replies.