Support » Plugin: Events Manager » Non compatible with php7.1 (+ fix)

  • The plugin (version 5.6.6.1) does not work on php 7.1.

    Error message appears upon activation:

    ( ! ) Fatal error: Uncaught Error: [] operator not supported for strings in /srv/www/domain.com/current/web/wp-content/plugins/events-manager/classes/em-events.php on line 63
    

    Only solution for now is to remove the plugin from the plugin folder to auto-desactivate it.

    See this page for a list of incompatible changes migating from php7.0 to php7.1.

    The fix is to replace the faulty line

    $groupby_sql = '';

    by

    $groupby_sql = [];

    And that’s it. It works.

    • This topic was modified 4 months, 1 week ago by pixeline.
    • This topic was modified 4 months, 1 week ago by pixeline. Reason: added a temporary fix
    • This topic was modified 4 months, 1 week ago by pixeline.
Viewing 2 replies - 1 through 2 (of 2 total)
  • caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    Thanks, I’ve passed this on to the Dev team.

    Plugin Author Marcus

    (@netweblogic)

    Hi, I’m sorry for the delayed reply. We’re working through various PHP 7 compatibility reports and trying to nail them all.

    We should have at least a dev version ready for download within the next few days, however the fix is pretty simple.

    On events-manager/classes/em-events.php on line 36 change this line:

    $groupby_sql = ”;

    to

    $groupby_sql = array();

    I believe that’s the only fatal error in PHP 7.1 (7.0 was tested and should be fine), but we’re working on various warnings/notices that cropped up since the .1 update.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.