Support » Plugin: AMP for WP - Accelerated Mobile Pages » Non-Amp Version link on blog posts page and category archives

  • Resolved frenchomatic

    (@frenchomatic)


    It seems that the link (Non-amp version) back to the canonical page for a category page or blog posts page – pages 2,3 etc is broken. It doesn’t return to the canonical which is rendered correctly in the meta area. The link only works correctly for the first page on an archive. I have only tested design 2.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor ampforwp

    (@ampforwp)

    Hi Frenchomatic,

    Could you send me the Proper Links and Screenshot on which you’re facing the issues so that I can check and let you know?

    Same problem

    It hurts SEO a lot:

    example. com /Hello World/page/2/ amp — error 404

    example. com /Hello World/ amp — redirect correctly

    example. com /Hello World/amp/page/2 — error 404

    How it works version: 0.9.97.9. ?

    I’m afraid to make more updates

    I will send by email. You should have it by now.

    • This reply was modified 7 months, 3 weeks ago by  frenchomatic.
    • This reply was modified 7 months, 3 weeks ago by  frenchomatic.

    The issue is easy to see – the canonical link in the meta data is correct for pages 2, 3, 4 … but a different url is being used for the Non-amp version link.

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi Manuwp09,

    Could you send me the Proper affected URL’s and Screenshot on which you’re facing the issues so that I can check it for your site and let you know about it?

    Hello:

    I sent an email
    I do not like to facilitate url by this means
    I do not provide access codes to wordpress
    The plugin needs an update to solve those errors
    In my case, if they are not solved, unfortunately I will not renew premium extensions

    Regards

    I have sent an email for this problem as well as the other issues currently posted on the forum by me. It is easy to see this problem on a demo system. The canonical link and the non-AMP version link are not the same for pages 2,3,4 … on a category page, a blog posts page or an archive.

    Also see this where you have already marked it as a bug

    https://github.com/ahmedkaludi/accelerated-mobile-pages/issues/2424

    • This reply was modified 7 months, 2 weeks ago by  frenchomatic.

    https://github.com/ahmedkaludi/accelerated-mobile-pages/issues/2424 Tested your commit and it solves this issue. I will mark it as resolved.

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi Frenchomatic,

    Sure.

    Thanks for testing our commit and updating us with that.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Non-Amp Version link on blog posts page and category archives’ is closed to new replies.