Support » Plugin: Yoast SEO » Noindex parameters sync with other lang version of post

  • Resolved Denis Creative

    (@denis-creative)


    When I specify the noindex parameter for one post, the same parameter is automatically set for all language versions of this post.
    For example, I need to make a noindex for the English version of a post, but indexing for the Ukrainian version. This does not work, because a single parameter is set for all language versions.
    Moreover, the descriptions and titles in each language version are different, as it should be..

    Screenshot – https://db.tt/sgnafbUA9z

    WordPress Version 5.7.2
    Polylang Version 3.0.5
    Yoast SEO Version 16.5

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Maybellyne

    (@maybellyne)

    Hello,

    Thanks for reaching out.

    For context, can you please share the URL of an affected post?

    Thread Starter Denis Creative

    (@denis-creative)

    For example test site

    Plugin Support Maybellyne

    (@maybellyne)

    In this example, the EN version has an index tag but you want it as noindex. Is that right? The UKR version has index and you want it that way.

    So we tested your scenario where a language is set to noindex and its corresponding translation is set to index. And it worked! We suspect the problem may be how you set the noindex/index.

    Can you please share how you specify the noindex parameter?

    Thread Starter Denis Creative

    (@denis-creative)

    At the settings YOAST SEO -> Advanced I set no at “Allow search engines to show this Post in search results” https://db.tt/mpfTGAIy4h and after that press Update.

    But I get the same result that noindex is set for the linked post in Ukrainian lang.

    Thread Starter Denis Creative

    (@denis-creative)

    This problem occurs specifically for posts that are linked in different languages.
    https://db.tt/0QbtAfkA2q

    Plugin Support Maybellyne

    (@maybellyne)

    Thanks for sharing.

    Indeed, if you have set ‘No’ in the EN version for ‘Allow search engines to show this Post in search results’, it should be noindexed.

    Often, we see problems occur in combination with another plugin or theme. The fastest way to rule out any conflict, is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Twenty.

    Please test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin has a troubleshooting mode, which does not affect normal visitors to your site.

    If you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts

    If you do not feel comfortable to do this yourself or if this does not solve your issue, our Yoast SEO Premium plugin comes with one year of (technical) support.

    Thread Starter Denis Creative

    (@denis-creative)

    This is dev site for the Test link

    Now Its active only Polylang and Yoast SEO.
    Theme is Twenty Twenty-One Version: 1.3
    All parameters from Site Health by Health Check & Troubleshooting is Good.

    The problem is observed on several sites, that is, it is due to the work of the plugin Yoast SEO. Fields in the Advanced section with dropdown fields or radio buttons are synchronized and not set unique for different language versions.

    WordPress Version 5.7.2
    Polylang Version 3.0.5
    Yoast SEO Version 16.5
    Theme Twenty Twenty-One Version: 1.3

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @denis-creative

    We did try to recreate this as well with a default TwentyTwenty WP theme and only Yoast SEO v16.5 and Polylang v3.0.5 as the 2 plugins enabled.

    We translated a post into a second language, and we do see that whatever you’ve set in the advanced tab of the Yoast SEO meta box automatically reflects in the translated post as well. We understand you want to set one version of the post to ‘index’ but might want to set the translated version to ‘noindex’ or vice versa.

    Thank you for bringing this issue to our attention. We’ve added the information you’ve provided in this forum thread to our internal issue tracker.

    Our product team will assess the severity of this problem in relation to other open bug reports and new features. Based on their assessment, the bug report will be given a priority level. Our developers work on the highest priority issues first. Unfortunately, this means we cannot give you an estimate of when they’ll start working on your report.

    As of now, there is no temporary workaround. If you have any further information that may affect the prioritization or help our development team solve this bug, please feel invited to reply to this forum topic.

    • This reply was modified 1 year, 5 months ago by Michael Tina.
    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

    Thread Starter Denis Creative

    (@denis-creative)

    But the problem has not been resolved yet. It will be resolved when you make changes to the plugin. At the moment, you have only confirmed that the problem is, and someday it will be fixed.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Noindex parameters sync with other lang version of post’ is closed to new replies.