WordPress.org

Support

Support » Plugins and Hacks » Platinum SEO Pack » Noindex of sub-pages no longer working

Noindex of sub-pages no longer working

  • Jon

    @jonpaulwade

    I have just noticed that a new sub-page got indexed. I checked the page and it is set to index,follow,noydir for /page/12

    In the settings Use noindex for sub pages: is ticked.

    I thought that it was working when I installed it. It is still works for category sub-pages ok. e.g. for /category/widgets/page/2 it shows noindex,follow,noydir

    Shouldn’t the homepage sub-pages also be noindex?

Viewing 1 replies (of 1 total)
  • There is a warning due to get_comment_pages_count() on line 286 of platinum_seo_pack.php. Probably the same issue, because it is there to suppress indexing past page 1 of the comments.

    I see this warning if I turn on WP_DEBUG in wp-config.php:

    Notice: Undefined property: WP_Query::$comments in … wp-includes/comment.php on line 738

    The reason is that $wp_query->comments is not yet defined. Since not yet in the loop?? It does get defined later.

    Anyway, sounds like the same problem you are having.

Viewing 1 replies (of 1 total)
  • The topic ‘Noindex of sub-pages no longer working’ is closed to new replies.
Skip to toolbar