Support » Plugin: Yoast SEO » NoIndex not working?

  • Resolved miquelmontoya

    (@miquelmontoya)


    Hi,

    I have looked through the forum but have not found any other topics that helped solve the issue.

    First, my technical knowledge is very basic so probably I am missing something very simple, but I have been going in circles for a bit so I would appreciate if somebody here could help me.

    There are currently a lot of my pages related to products (taxonomies) that are being indexed by Google. However, they are thin content and I don’t want them to be indexed. I have gone into the Search Appearance section of the plugin and set to “No” all the taxonomies. Despite that, there are still around 1.000 pages that are being indexed, even though they are set to noindex.

    The one above is just one example. When I go into the page and into the settings of the Yoast plugin, it states “Allow search engines to show this EANList in search results? – No (Current default…)”.

    Any idea why this is happening? Could it be a problem with WooCommerce or WZone that I am also using?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • The advanced tab (gear icon) inside the Yoast SEO meta box on the edit screen of the item allows administrators and editors to set custom robots information like noindex, nofollow, and other advanced robots settings.

    To allow authors access to this tab, go to SEO->General->Features and toggle the Security: no advanced settings for authors to ‘Off’.

    The layout may vary as the example above is from a default post type.

    Yoast SEO Metabox : Plugins Tab – Googlebot-News index
    Yoast SEO: News includes the ability to tell Google News not to index a specific news article. This option is found under the plugins section of the metabox in the ‘Google News’ tab. Learn more about using Yoast SEO: News here.

    Noindex All Categories, Tags or Other Taxonomies
    If you want to noindex a group of items, enable this feature using the steps below. By default, search pages and 404 pages will be set to noindex, follow.

    Hi antman1221,

    Thanks for the message. I have set the Security to off. However, I don’t really understand how that helps as I have already set the specific taxonomies I am having problems with to noindex.

    My problem is that, even though that is set to noindex, Google is still indexing it. When I go to Google Search Console and check that specific page within the robots.txt Tester, it tells me that the Googlebot is allowed. I think it should not be allowed as I have put it to noindex, but maybe I am missing something.

    Could you please clarify?

    Thanks!

    Hi again,

    It looks like, whenever I test the URL live, it appears that the noindex is there, so the problem seems solved. However, the pages still appear in the Google Index part of my Search Console. Does somebody know how long it takes for them to disappear from there?

    Thanks!

    Plugin Support Michael Tina

    (@mikes41720)

    Hello,

    If they were previously set to ‘index’ and you have just recently set them to ‘noindex’, it’s understandable that it would still appear in the search results. When Google is able to crawl your website again and check on the pages with the ‘noindex’ tag, it should be able to update the information and drop it from the index. Unfortunately, we are unable to specify a given time frame as it depends on how often Google crawls your website.

    Thanks Michael,

    That is clear now!

    Plugin Support devnihil

    (@devnihil)

    @miquelmontoya We checked on the https://www.architectgadgets.com/eanlist/0601285150222/ page and confirmed that it has a ‘noindex’ robots metatag in the source code. We are going ahead and marking this issue as resolved. If you require any further assistance please create a new issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘NoIndex not working?’ is closed to new replies.