Support » Plugin: Google XML Sitemaps » Noindex in sitemap.html and sitemap.xml

  • obunabali

    (@obunabali)


    after some few days i installed xml sitemap, I checked my google webmaster tools, and find out my coverage has an error from this plugin, and it was boldly stated that the both sitemap extension sitemap.html and sitemap.xml has robot no-index in it, and which google had problem with, anyway i have edited the plugin an remove all the no-index on it, my site url is https://naijgreen.com/

Viewing 12 replies - 1 through 12 (of 12 total)
  • filippo94

    (@filippo94)

    Uncheck “Include sitemap in HTML format” and save.
    Then click “debug function” and in the bottom click “Rebuild”.

    • This reply was modified 2 months ago by filippo94.

    I too have the same problem. I followed the instructions, for now it gives me “error 404”

    seeing the history of errors, the problem began on November 10th, before it was not there

    Got the same issue, the html site map shows at google webmaster as an error with noindex

    Uncheck “Include sitemap in HTML format” and save.
    Then click “debug function” and in the bottom click “Rebuild”.

    This did not do the trick, still the same issue:
    <meta name=”robots” content=”noindex,follow”/>

    • This reply was modified 1 month, 3 weeks ago by intered.

    Same here although am not getting 404 after turning off sitemap in html and rebuilding in debug. what’s happened anyway plugin developers? Am thinking about going static with my sitemap as it’s most reliable way and less prone to plugin errors in particular for sites that don’t change content too often.

    Cheers,
    David

    • This reply was modified 1 month, 3 weeks ago by davss.

    No word yet… hope this getting fixed asap in the next update!

    I’m just thinking, since html version of sitemap is for humans only isn’t it correct that it shouldn’t get indexed by google to avoid any confusion or affect xml version designated for search engines?

    could be a point, but if so, then it should not be included in the sitemap at all

    same problem here! got notified by google last night… grrr

    google check finished! Even raising the sitemap in html and rebuilding from debugging, the problem remains. By disabling the plug-in, the problem disappears.

    I think this should be correct i.e. ‘noindex’ but ‘follow’ set in sitemap.html only.

    However, both XML and HMTL contain:

    “This is a XML Sitemap which is supposed to be processed by search engines which follow the XML Sitemap standard like Ask.com, Bing, Google and Yahoo.
    It was generated using the WordPress content management system and the Google Sitemap Generator Plugin by Arne Brachhold.
    You can find more information about XML sitemaps on sitemaps.org and Google’s list of sitemap programs.

    This file contains links to sub-sitemaps, follow them to see the actual sitemap content.”

    Which is incorrect.

    Not sure why GWT is complaining about it when there is an .xml version available + how/what is linked to html version as well as why google can’t ignore ‘noidex’ for html?

    • This reply was modified 1 month, 3 weeks ago by davss.

    I disabled html sitemap and rebuilt it in Debug then requested check in Google Webmaster Tools 4 days ago. Today got this:

    “Coverage issues successfully fixed for pages in sitemap /sitemap.xml on site kancelaria.info

    To owner of https://kancelaria.info,

    Google has validated your fix of Coverage issues on site kancelaria.info. The specific issue validated was ‘Submitted URL marked ‘noindex’’.

    1 pages on your site were validated as fixed.

    To examine full details on the validation progress and to find out if there are other Coverage related issues to fix, please follow this link.”

    Therefore confirm the suggested above fix does work.

    I also want to confirm un-checking HTML Sitemap, debugging, asking Google Search Console to validate the fix, worked for me.

    From Search Console today: Google has validated your fix of Coverage issues on site “my Site”. The specific issue validated was ‘Submitted URL marked ‘noindex’’.

    1 pages on your site were validated as fixed.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.