Support » Plugin: Yoast SEO » noindex for Tags doesn’t work

  • Resolved ArtakEVN

    (@artakevn)


    Hi. Trying to remove tags archive from search results.
    Search Appearance -> Taxonomies -> Tags -> Show Tags in search results? -> No

    Unfortunately Source Code still shows <meta name=”robots” content=”index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1″ />

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We would like some more information.

    1. Are all your non-Yoast plugins and themes also updated?

    2. We had another recent release. Can you confirm you are using the most recent Yoast SEO, v15.2.1? If you update, does the issue resolve?

    3. Does clearing your caching from your theme, plugin, server, CDN like CloudFlare or browser resolve the issue? If you are not sure how to clear caching from theme/plugin please speak to those authors. If you want to clear cache from the server, please speak to your host provider. To clear the cache from a browser use this guide: https://yoast.com/help/how-to-clear-my-browsers-cache/

    4. Can you provide a link that highlights the issue?

    Thread Starter ArtakEVN

    (@artakevn)

    Hi.
    Thank you for quick reply

    1. Yes all plugins are updated.
    2. My version is 15.2.1 (free version)
    3. Cleaning cache etc does not resolve the issue. Functionality works for posts, pages, but not for tags (not sure about categories).
    4. https://beta.3rdfloortailors.com/blog/tag/wedding-reception/
    Also tried with default theme Twenty Twenty. Same result.
    Created staged version of my website at https://beta.3rdfloortailors.com/ for you. No caching plugin, no cdn.
    Access: beta/BetaMax2020

    if you want can give admin access to this staged version as well. Just need your email.

    • This reply was modified 10 months, 4 weeks ago by ArtakEVN.
    • This reply was modified 10 months, 4 weeks ago by ArtakEVN.
    • This reply was modified 10 months, 4 weeks ago by ArtakEVN.
    Plugin Support devnihil

    (@devnihil)

    @artakevn Thanks for your reply and for providing the test site.

    If clearing your site’s cache doesn’t resolve the issue with the tag pages still showing the robots meta tag as index, it’s also possible that the setting to set them to index may have been at the individual tag page level. Whereas you can set a global setting for tag pages under SEO>Search Appearance>Taxonomies for Tags, you can override the global setting for Tags on the individual tag page.

    Can you please check the following to see what the Tag page is set to?

      • In WordPress, go to Posts>Tags
      • Click the ‘Edit’ link beneath a tag
      • Scroll down to the Yoast SEO metabox
      • Click on the ‘Advanced’ area
      • For ‘Allow search engines to show this Tag in search results?’ ensure this is set to ‘No’
      • Click ‘Update’
    Thread Starter ArtakEVN

    (@artakevn)

    Thank @devnihil
    ‘Allow search engines to show this Tag in search results?’ for all tags is NO. And it is still showing as index
    However, setting value to YES, then back to NO did the trick.
    Thank you for workaround.

    Plugin Support devnihil

    (@devnihil)

    @artakevn Thanks for your reply and we’re glad to hear that corrected the issue.

    Hi there! I’m having the same issue in all the sites where I use Yoast with categories and tags. I’ll try the solution from @artakevn, hopefully, it works.

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @akawaiiworld,

    Thank you for chiming in here. Yes, please check the default setting and the tags individually to double check where the index originates from. If you still experience issues after checking the workaround, please create a new topic to get support.

    We are going ahead and mark this topic as resolved since the topic owner issue has been resolved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘noindex for Tags doesn’t work’ is closed to new replies.