Support » Plugin: Yoast SEO » Noindex, follow tag added to author Archives in error

  • Resolved willjames


    I have the correct settings in the search appearance -> Archives -> Author Archives

    The archives are set to ‘on’. The ‘Show author archives in search’ are on as are the ‘show archives for authors without posts’.

    I have tried deactivating other plugins but the only one that makes this disappear is when yoast is deactivated.

    I confirm that ‘Search engine visibility’ is not ticked under ‘reading settings’

    I have no other SEO – based plugin on the site (in fact it is happening to all three of my sites.)

    The base category for the authors are /dealer/

    I can confirm that the drop-off in landing page visits to author pages through Google happened from the middle of November. This coincided with the rollout of 19.10 on 8th November where: “The following hooks have been deprecated: …Yoast\WP\SEOdmin_author_archives_meta….”

    I have a dev site that you could access if required.

    Many thanks

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Maybellyne


    Hello @willjames

    Thanks for reaching out regarding your author archives.

    Since you set Show author archives in search and Show archives for authors without posts to ON, an author sitemap is also created at

    The sitemap has a mix of base category URLs, with some having /dealer/ while some /author/. Did you recently change the base category?

    For, I can confirm the strange noindex tag but that URL is not in the sitemap.

    You mentioned that the base category for the authors is /dealer/; this means the author archive should be but visiting that 301 redirects to And visiting redirects to /dealer/, then the above URL is the final destination.

    Also, I picked, and there is a 301 redirect to with the redirection plugin. Are you redirecting /author/ to /dealer/?

    I look forward to more clarification.

    • This reply was modified 2 months, 1 week ago by Maybellyne.
    Thread Starter willjames


    Many thanks for your response.

    The author sitemap is important to us but, because my theme uses a bespoke user role and capability that Yoast does not recognise, I have to use PublishPress Capabilities to add the user to the author sitemap by giving them two Roles (the Theme’s one and ‘contributor’). 

    I have tested with this plugin turned off on the dev site and the spurious noindex tag still remains until I deactivate the Yoast plugin.

    The reason that the A&M user was not in the sitemap was because the extra ‘contributor’ step had not been carried out (it has now).

    I can confirm that we are redirecting /author/ to /dealer/* but not for all users (we have different grades of users)

    Looking at the sitemap, user accounts that were added after June 2022 appear as /author/ in the sitemap, whereas those added before appear as dealer. If I edit and save a user, then they become /author/ in the sitemap (I want them to say dealer as this is what is actually the URL) .

    Looks like there was some work done on sitemaps just before this:

    I would simply like /dealer/ in the sitemap for all and no ‘noindex’ tag on these pages as both issues are costing me traffic and customers.

    Many thanks for your help

    Plugin Support Maybellyne


    Thanks for providing more clarification.

    Two changes in Yoast SEO 19.0 that relates to sitemaps are making the sitemap available to Bing and adding the Yoast-generated XML sitemap URL to the robots.txt file. I’ve checked, and this is correctly implemented for your site.

    By the way, I still don’t see in the sitemap; that’s definitely due to the noindex tag. Can you edit the user/author and ensure that Do not allow search engines to show this author’s archives in search results is unchecked?

    Thread Starter willjames


    I can see the in the sitemap. I can confirm that Do not allow search engines to show this author’s archives in search results does not even exist for my installation – there is no Yoast box at the bottom of the page as with other types.

    All of the author (dealer) accounts shown in the sitemap have the same issue, it is not just this one, so feel free to try any of them listed.

    To summarize:

    Problem 1: Sitemap shows /author/ instead of /dealer/ in sitemap

    Problem 2: The noindex tax on every dealer (author) page.

    Thanks for your help

    Plugin Support Maybellyne


    You’re correct! I can see in the author sitemap now.

    I’m still figuring out your setup and what’s responsible for the noindex tag; I understand with a noindex tag, the URL shouldn’t be in the sitemap. Deducing from what you mentioned, I assumed dealers/authors are user accounts found in WordPress > Users > All Users; is this correct?

    The issue might be between Yoast SEO, PublishPress Capabilities and Redirection plugin. Unfortunately, I’m unable to replicate your setup and re-create the issue at my end. Troubleshooting the issue further will involve taking a closer look at my setup which we can’t do on a public forum. You may consider purchasing a Yoast SEO Premium subscription that involves email support.

    Thread Starter willjames


    I assumed dealers/authors are user accounts found in WordPress > Users > All Users; is this correct? Yes This is correct

    I can confirm that the issue is still there with both Redirection and PublishPress turned off. It is only when Yoast is turned off that this appears.

    I am not happy buying a licence for a product that does not work on my site, I might be better buying a licence for a different product that does work?

    I have a development site that is availabile…?


    Thread Starter willjames


    I have discovered a workaround for the noindex issue but still do not have an answer to the sitemap dealer-> author renaming issue.

    I have added the following to the functions.php file:

    //Removes the Yoast noindex on author pages and makes it index
    add_filter( ‘wpseo_robots’, ‘yoast_seo_robots_remove_author’ );
    function yoast_seo_robots_remove_author( $robots ) {
    if ( is_author() ) {
    return null;

    add_filter(‘wp_robots’, ‘my_wp_robots_directives’);
    function my_wp_robots_directives( $robots ) {
    if ( is_author() ) {
    unset( $robots[‘max-image-preview’] );
    unset( $robots[‘noindex’] );
    $robots[‘index, follow’] = true;
    return $robots;

    Any thoughts on the fix and regarding the sitemap issue?

    Plugin Support Maybellyne


    You mentioned redirecting /author/ to /dealer/ with the Redirection plugin. However, by design, when a 301 redirect is created with a third-party plugin, this isn’t included in the Yoast-generated XML sitemap.

    Thread Starter willjames


    I am not using the redirection plugin for this but ‘Combo WP Rewrite Slugs‘ which is a rewrite instead of redirection. I am struggling why the earlier ones were included in the sitemap as /dealer/ and later ones not included. Something has changed with the Yoast plugin as the other plugin was not changed at this time?

    Plugin Support Jeroen Rotty


    We’re not familiar with that plugin so we’d recommend reaching out to the developers/support team of that relevant plugin and see how that can work in combination with Yoast SEO.

    Thread Starter willjames


    …Or delete yoast and move onto a different plugin. That plugin hasn’t changed, Yoast has. I spent time setting Yoast up and it was working. Now it is not. That’s a shame that I have to do it all over again with my sites with a different SEO plugin. Thank you for all your help!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.