Support » Plugin: Google XML Sitemaps » “noindex” error in Google Search Console

  • Hallo and greetings from Germany! Google Search Console shows me a “noindex”error for
    https://metallbau-nielsen-sylt.de/sitemap.html, it started in February the 25, i changeed nothing. I also use Yoast Seo, but i deactivated the Sitemap there. Any Idea what the Problem could be? Thank you very much!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 16 through 21 (of 21 total)
  • thiagolucio

    (@thiagolucio)

    wtf

    thiagolucio

    (@thiagolucio)

    dude just remove this shit,

    line 1576 sitemap-core.php

    //Do not index the actual XML pages, only process them.
    //This avoids that the XML sitemaps show up in the search results.
    if(!headers_sent()) header(‘X-Robots-Tag: noindex’, true, 200);

    seriously?

    thiagolucio

    (@thiagolucio)

    remove this shit from sitemap.xsl

    <meta name=”robots” content=”noindex,follow” />

    • This reply was modified 2 weeks ago by  thiagolucio.
    thiagolucio

    (@thiagolucio)

    lets the use decide what will appear in search results ok?

    thiagolucio

    (@thiagolucio)

    how can we update this plugin again whe this dumb shit will load this noindex no sense? I am considering another sitemap plugin already

    Hi all,

    Same problem suddenly appeared here after WP 4.9.5 update :(, and Google Webmaster Tools is complaining about my sitemap being in HTML format. As suggested, I have unchecked “Include sitemap in HTML format”, but I would assure that I have never checked/unchecked this option before…

    Hope this solves the problem. Thanks very much in advance.

    Best regards,
    Miguel

Viewing 6 replies - 16 through 21 (of 21 total)
  • You must be logged in to reply to this topic.