Support » Plugin: Google XML Sitemaps » “noindex” error in Google Search Console

  • annoy

    (@annoy)


    Hallo and greetings from Germany! Google Search Console shows me a “noindex”error for
    https://metallbau-nielsen-sylt.de/sitemap.html, it started in February the 25, i changeed nothing. I also use Yoast Seo, but i deactivated the Sitemap there. Any Idea what the Problem could be? Thank you very much!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • xgstq

    (@xgstq)

    Im seeing the same error as well

    I have sitemap.xml in my robots.txt but as annoy says im also getting errors in my web master tools relating to sitemap.html

    Submitted URL marked ‘noindex’

    If I view source:

    <meta name=”robots” content=”noindex,follow”/>

    • This reply was modified 1 month ago by  xgstq.
    ronalds

    (@ronalds)

    Does this require a plugin update? Anyone able to shed some light on a fix for this?

    DOAADI

    (@doaadi)

    Apparently, if it’s only categories which are being flagged then there’s nothing to worry about.

    You may find that your SEO plugin is set to apply noindex to categories (or other things) in its settings page, and that’s why it happens.

    eharris

    (@eharris)

    DOAADI – No, as a previous poster said, the problem is with the siteindex.html file that this plugin generates. The whole purpose of this plugin is to produce site indexes, and it produces a site indexing error. That sure seems like a plugin bug to me.

    • This reply was modified 1 month ago by  eharris.
    ronalds

    (@ronalds)

    I don’t have any particular plugin for SEO like Yoast or such. I am not sure where to look to remove this error. I am considering trying other sitemap plugins at this point.

    xgstq

    (@xgstq)

    Ive disabled this one and reverted back to Yoast’s. Im only indexing posts & pages which Yoasts dones fine.

    Remember to update webmaster tools sitemap and crawl it

    I use this plugin on two sites. One has this problem, the other doesn’t (yet).

    I disabled “Include sitemap in HTML format” on the problem site. We’ll see what happens…

    BTW, the HTML version wasn’t validating properly anyhow.

    mvwebdigital

    (@mvwebdigital)

    I’m having the same problem on all my sites!
    Is it going to have a result? or will I have to stop using the plugin?

    mirgcire

    (@mirgcire)

    Sounds like I am have the same problem as above. Currently, the GXS plugin is reporting 5 pages to Google Search Console that are not in my web site. However, the names of the files sound like pages on my site, so they may have existed at one time. I searched all the records in the DB using myphpadmin and these names are not present. It seems pretty mysterious to me …. hope you GXS guys are working on this now. Thanks!

    Disabling “Include sitemap in HTML format” resolved the problem.

    woke up with a message from my google search console same as above – but so far only one of the sites i support had gotten the error (Which is strange as most of my sites are set up the same with this plugin) – as per rcharbonxx above, i turned off Include sitemap in HTML format and resubmitted to see if that will fix it (thank you sir)
    it would be nice to hear from the developer on this issue as it appears to have been happening for over a week . . .
    i have been using this plugin on many sites for over 6 years now with no issues . .. so don’t understand what’s happening

    @rcharbonxx: Thanks for your solution! I confirm that disabling “Include sitemap in HTML format” resolved the problem.

    estudarememorizar

    (@estudarememorizar)

    the same here… I disabled “Include sitemap in HTML format” and now I’m waiting for google console validation…

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.