Support » Plugin: Redis Object Cache » NOAUTH Authentication required.

  • Resolved torsten3d

    (@torsten3d)


    Hi,

    i’m on a Managed Server and have REDIS active, but struggle with the common NOAUTH-Problem. I had read all the threads, but couldn’t find a solution for me, so i asked my Managed Server Team, which Password i need.
    They said, that i don’t need one and the software who asks for Passwort is outdated.
    Can’t believe this, cause nobody else mentioned that in his thread.
    So what could be a solution on my site?

    Best
    Torsten

    My actually diagnosis:

    Status: Nicht verbunden
    Client: PhpRedis (v5.3.4)
    Drop-in: Valid
    Disabled: No
    Ping:
    Connection Exception: NOAUTH Authentication required. (RedisException)
    Errors: [
    “NOAUTH Authentication required.”
    ]
    PhpRedis: 5.3.4
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.4.26
    Plugin Version: 2.0.22
    Redis Version: Unknown
    Multisite: No
    Metrics: Disabled
    Metrics recorded: null
    Filesystem: Working
    Global Prefix: “wp_kalender_”
    Blog Prefix: “wp_kalender_”
    Global Groups: [
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “redis-cache”
    ]
    Ignored Groups: [
    “counts”,
    “plugins”,
    “themes”,
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “redis-cache”,
    “blog_meta”
    ]
    Unflushable Groups: []
    Drop-ins: [
    “Query Monitor Database Class v by “,
    “maintenance.php v by “,
    “Redis Object Cache Drop-In v2.0.22 by Till Krüss”
    ]

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    You need to set the WP_REDIS_PASSWORD constant:

    
    define('WP_REDIS_PASSWORD', 'mega-geheim');
    

    The NOAUTH Authentication required means the server is expecting a password, your support team is wrong.

    Thread Starter torsten3d

    (@torsten3d)

    Hi Till,

    thanks for your fast response. So after a few more words with the team, we found out, that there was a misunderstanding. There is a password of course and now everything is fine.

    I hast have to figure out, while loading times in backend are now around 4 seconds instead of 2. I’d expected it faster than 2 of course…

    Thanks,
    Torsten

    • This reply was modified 7 months, 3 weeks ago by torsten3d.
    Plugin Author Till Krüss

    (@tillkruess)

    Glad you figured it out!

    If your site is slower with object caching enabled, then it’s usually Redis Server not having enough power to serve your sites requests fast enough.

    Thread Starter torsten3d

    (@torsten3d)

    Hi Till,

    around half an hour after sending my message, the speed was better than before (around 25%) for loading times. Strange, cause the plugin said everything is fine from beginning and delivery ratio was near 100%.

    But finally everything is OK now 🙂
    Thanks,
    Torsten

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘NOAUTH Authentication required.’ is closed to new replies.