Support » Installing WordPress » No WYSIWYG Editor in 2.1

  • Our new tabbed editor allows you to switch between WYSIWYG and code editing instantly while writing a post.

    After upgrading to 2.1 everthing works fine, but I can’t find a ‘tabbed editor’. Just get a plain text editor.

Viewing 10 replies - 61 through 70 (of 70 total)
  • Thanks for the help. I seem to have kinda the same problem under firefox. I could not click anything + could not write in the body section. Resizing the visual “frame” seems to reset the controls and everything works great now !

    Whoooho I dont need to use IE anymore !
    Chris

    Oups never mind my last post. The controls work but now I cannot save ! Saving clears the hole page/post!

    Dang
    Chris

    Fresh WP install, never had WYSIWYG editor, please help!

    Hi guys. I have never even seen the “Editor”-tab you are supposed to see when editing posts. There is no option for activating Rich Text Editor in “Options” – “Writing”.

    I am running a clean install of WordPress 2.1.2.

    Could anybody be so kind as to point me out in the right direction?

    The option for activating Rick Text Editor is in the user’s profile, not in the options. It worked for me! =)

    Peace,
    Savakabuddha

    Just to add gasoline to this fire, I can see the editor tabs fine, but my co administrator who is in another location can’t.

    Figure that one out

    I’d suggest that the co-admin needs to visit Users -> Your Profile and check that box to use the visual editor.

    I have got this problem.

    Here is the way to resolve.

    Backup your database, plugins and attachments, and then delete all and upload the wp2.2, config the wp-config.php.

    Then everything works 😉

    I recently installed two new 2.2s, one works perfectly but the other has no formatting buttons at all (though I’m sure they were there at first- I did post an opening article and I’m sure I’d have noticed ;).

    I’ve done all the recommended fixes, checking and unchecking visual editor in profile, clearing the cache and forcing reload, adding www, and even jkeegan2’s fix though the file has been updated in 2.2 anyway, all to no avail.

    All I have is the two tabs (Visual and Code) and clicking on them makes no difference at all – the view shows the post with <p> tags so I assume it’s the code view, but it won’t change to visual. Any help will be much appreciated, though I think I’ll just re-install – though by the sound of it that won’t necessarily solve the problem!

    First, I’m totally ignorant, just a user and not even the person who set the dern thing up. For me, with 2.2 everything worked fine for the first fifteen or so posts, but I went to post number sixteen and everything was in code. There were no buttons and clicking on the visual tab only “depressed” it…but nothing happend. All the previous posts on the blog are in code also.

    I don’t know whether this has anything to do with anything, but I’ve worked with Word since forever it seems. I can’t write on that little window, plus I like to be able to work on my posts over several days, overlapping the progress etc. So I’ve composed in Word, stripped all of the Word coding in NotePad, then cut and pasted that into WP’s window.

    Anyway, I’ve tried editing from both my computer and another computer; same result. And sorry if I sound like I don’t know what I’m talking about because I don’t, but most of the suggestions have gone completely over my head, or if I know what they are in general terms, I don’t know how to implement them. E.g., clearing a cache? I didn’t know I had one.

    When I go to post, Firefox Error Console shows:

    Error: tinyMCE.getInstanceById is not a function
    Source File: website/js/autosave.js?ver=20070306
    Line: 99

    as well as
    Error: missing ; before statement
    Source File: website/wp-includes/js/tinymce/tiny_mce_config.php?ver=20070225
    Line: 2, Column: 9
    Source Code:
    Parse error: syntax error, unexpected ‘[‘ in tiny_mce_config.php on line 25

    Hope this helps, I’d like to get the situation resolved as it arised out of thin air

Viewing 10 replies - 61 through 70 (of 70 total)
  • The topic ‘No WYSIWYG Editor in 2.1’ is closed to new replies.