WordPress.org

Support

Support » Installation » No WYSIWYG Editor in 2.1

No WYSIWYG Editor in 2.1

  • Our new tabbed editor allows you to switch between WYSIWYG and code editing instantly while writing a post.

    After upgrading to 2.1 everthing works fine, but I can’t find a ‘tabbed editor’. Just get a plain text editor.

Viewing 15 replies - 1 through 15 (of 70 total)
  • Did you switch on visual editor on?

    User -> Your Profile

    Under your USER profile in the wp-admin, under Personal Options (located at top), make sure there is a check in the checkbox for: “Use the visual editor when writing”

    I believe this is right, I really don’t use that anymore, so.. Good luck either way though! ;):)

    spencerp

    Can’t find any checkbox – is it a database thing – I switched off visual editor in 2.0.7 before updating

    I have a similar issue, in that the Visual editor is on, yet all the text tools are missing, the only tools present are Bold, Italic, split post and spell check.
    None of the others are present .

    I have reinstalled and the issue remains.

    Are you sure that you’ve DELETED all the files, except for the wp-content/ folder, wp-config.php and .htaccess file, and then reuploaded NEW FRESH files for the 2.1 stuff?

    That includes for the files under the wp-includes/,wp-includes/js/ folders too.

    spencerp

    I am having a similar problem. For me everything works correctly with rich text turned off. When I enable it I see the tabs, but they are not click-able, and there are no other buttons for formatting or anything. I Did the full install, replaced every single thing except my themes and the few important files. This problem exists with or without plugins activated.

    After reinstallation my WYSIWYG editor finally works, but I’m back to the old problem with the linebreaks. Nor Shift+Enter neither 2 x Shift gives me a line break

    Sorted!
    Reinstalled deleting the old wp install first.

    try ctrl+f5 or shift+f5 if the only tabs in the rich editor are bold, italic, toggle and split cells. worked for me, tho insert link/image tabs have some errors. i mean, none of the X, cancel or insert buttons work.

    Cleaning the browser cache helped for me too!

    deleting the cache does nothing for me. No formating options show at all. The tabs between visual and code are not even click-able. I’m not sure what to do.

    In either Safari or Firefox, I can enter text only if the RTF is unchecked in my profile. With RTF unchecked, I get all the buttons but no visual/code tabs. When RTF is checked, I get only some of the buttons, I get the tabs, but they aren’t clickable, and what’s stranger, I cannot enter any text. I can enter the title of the post, but nothing in the body. I have reinstalled wht TinyMCE stuff, cleared my caches, everything suggested here. Nothing works.

    Make sure that all scripts in your browser are enabled.

    All my scripts are enabled.

    Did that. Makes no difference.

Viewing 15 replies - 1 through 15 (of 70 total)
  • The topic ‘No WYSIWYG Editor in 2.1’ is closed to new replies.
Skip to toolbar