WordPress.org

Support

Support » Installation » No WYSIWYG Editor Icons WP 2.2.3

No WYSIWYG Editor Icons WP 2.2.3

  • texbiker
    Member

    @texbiker

    I just installed the update to 2.2.3 and now when I try to post there is no WYSIWYG editor icons. The two tabs are there but you cannot select either one. If I save and continue I get some html code appearing but no icons.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Chris_K
    Member

    @handysolo

    Have you tried flushing the browser cache?

    Ctrl-F5 is a shortcut to force a reload of the page in IE and FF. Try that?

    texbiker
    Member

    @texbiker

    My original post was using Firefox so I tried IE and get the same result. Trying a forced refresh does not change anything either.

    MichaelH
    Member

    @michaelh

    There is the possibility all the 2.2.3 WordPress files didn’t get completely uploaded.

    texbiker
    Member

    @texbiker

    I checked the Admin folder and all of the files are there and new if need to be.

    skysquare
    Member

    @skysquare

    I am having the same problem since upgrading half and hour ago, together with this one http://wordpress.org/support/topic/133304?replies=2

    I upgraded from 2.2.2 to 2.2.3.All files were uploaded correctly but I just overwrote the old ones.

    I just did a fresh install, deleted the old ones first,flushed the cache etc – still the editor icons won’t work….

    skysquare
    Member

    @skysquare

    I got it fixed!

    Firefox gave me a hint on the extras>errors display…

    On the base of this solution by jkeegan2

    http://wordpress.org/support/topic/104627?replies=5#post-512864

    Go to wp-includes\js\tinymce\tiny_mce_gzip.php and open the php-file.

    Find the line given here: http://trac.wordpress.org/attachment/ticket/3144/3144-gzipoptoins-tinymce.patch
    (should be line 87)

    As you can see in previous versions this line ends with

    && !ini_get('zlib.output_compression')) {

    In WP Version 2.2.3 it ends with
    && ini_get('output_handler') != 'ob_gzhandler') {

    REMOVE this added code at the end and REPLACE it with
    && get_settings('gzipcompression')) {
    (as shown on the trac-site)

    Save/upload the changed “tiny_mce_gzip.php” and refresh the ‘writing post’-interface with ctrl+F5 > visual editor should be back.

    halinagold
    Member

    @halinagold

    I appreciate the suggestion. Still, I’d rather see the bug fixed in the 2.2.3. core code rather than I don’t know how many WordPress users having to make individual changes there…

    texbiker
    Member

    @texbiker

    It is good to know what the problem is.

    I agree with halingold about fixing the file that should have been fixed in the release. While I await the fix I have installed the Dean’s FCKEditor For WordPress plugin. If you need it the link is here.

    skysquare
    Member

    @skysquare

    That’s absolutely right. Security reasons is okay, but if it turns out I’m actually sort of downgrading…
    I chose wordpress for not having to get in touch with programming but just writing and layouting, I hope this whole trouble lessens…

    halinagold
    Member

    @halinagold

    Thanks a million texbiker!
    It’s new to me and I love it. I think I’m going to use it regardless of the bug being fixed or not…

    By the way, a direct link to the plugin page is here.

    🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘No WYSIWYG Editor Icons WP 2.2.3’ is closed to new replies.