Support » Plugin: Classic Editor » No WYSIWYG

Viewing 15 replies - 1 through 15 (of 15 total)
  • Im having the exact same issue. I have tried everything to resolve this but no luck.

    Can you please advise?

    Ramires

    (@ramiressilva)

    Me too, I could not find a solution. Someone?

    First option would be to check if there is no conflict with any other plugins by disabling all other plugins, and if Classic Editor works while the other plugins are disabled then check what plugin is causing the conflict by one by one enabling the plugin until the conflict reappears, then to check if its specifically that plugin then disable all plugins again and leave enabled the Classic Editor plugin and the plugin that gave the conflict when enabling, if the problem then still persists then you know where the conflict is and you by example can ask the plugin author to have a look. If its a conflict with Yoast SEO plugin then it should get solved soon, there are more people having that problem so the plugin should be updated when a new version is released.

    Second you can also check if there is a conflict with the theme you are using by switching to one of the default themes.

    Third: there also seems that in some cases there can be conflict with the Firefox browser (maybe blocking specific scripts) so when you have an alternative browser then check if it works in another browser.

    Fourth: you could instead of Classic Editor try the Disable Gutenberg plugin (https://wordpress.org/plugins/disable-gutenberg/) maybe that can a solution or a temporary solution until the problem is solved. Then disable the Classic Editor and enable the Disable Gutenberg plugin.

    Fifth: make sure that no htaccess files are causing problems.

    @damsko Thanks for the options but unfortunately none of them solved the problem…

    OK, shame… good luck in your quest pinpointing the problem, it can be a real pain.

    Final straw if you depend on the classic editor and no solution presents itself could be reverting to the WordPress 4.9 branch and keeping that up to date with the latest security releases: https://wordpress.org/download/releases/ (thats what i’m currently doing while contemplating what to do in the future) or to try the ClassicPress fork.

    Any updates on a fix? I have the same issue.

    Tried reinstalling WordPress and still have the problem. This is a fresh install with no other plugins. I get only a media upload button and the text box. But the text box is also broken because when you type in it the text is white (inside the white box thus you can’t read it). The “Visual/Text” buttons on the right also are not clickable.

    In other words… it all broke. Is my only option to actually use Gutenberg? NOOOOOO.

    • This reply was modified 3 months, 2 weeks ago by  handlas.

    Im having the exact same issue
    1)I have disabled all my WordPress plugins(NOT WORKING)
    2)I tested with the default theme (NOT WORKING)
    3)I used Disable Gutenberg plugin (NOT WORKING)
    4)I returned to WordPress 4.9 (OK)

    Attention
    you can disable automatic updates in WordPress by adding this line of code in your wp-config.php file

    define( ‘WP_AUTO_UPDATE_CORE’, false );

    • This reply was modified 3 months, 2 weeks ago by  Redbullnik.

    I’ve just experienced this, and for me, deactivating the Yoast SEO plugin fixed it. Obviously, this is NOT a valid solution, as Yoast is a big daddy plugin that is on most all of my sites. Hoping this thread gets some traction because this is a pretty urgent conflict to resolve…

    Noup…

    I have make all things except downgrade… No solution for me.

    Aditionaly also reinstal, use the “reset WP” plugin to clean DB and nothing… +

    It is really weird because is just with one site, with my other sites, BEFORE de update I install the classic editor plugin and just fine.

    Hope some can Help us.

    Thanks all <3

    Disabling yoast and all plugins does not work for me. Like @robbie3 this is only effecting some of the 65 sites I have built and manage. They all have the same setup as in theme, plugins and hosting so its really strange. I have gone through everything I could on my end and got my hosting provider, Siteground to check everything on there end but still no luck. I would really appreciate if this could be addressed urgently as my my clients cannot update there site properly and I have had to revert to a backup with WordPress 4.9.8 installed…

    I finally managed to resolve the issue. There was a .htaccess file in the wp-includes folder which I renamed and all is working fine now.

    Hope that helps…

    Ramires

    (@ramiressilva)

    @karll10, renaming .htaccess in the wp-includes folder did not solve the problem, and the file is always re-created.

    It worked for me but i suppose everyones setup is different…

    alphavisual

    (@alphavisual)

    I have Elementor and I can’t see WYSIWYG either or the HTML etc. Maybe creating a fancy editor to replace classic might not be the best feature to add to new versions of WordPress because there are a number of really good editors already out there and there is a lot of testing that goes on to ensure these components work properly in different browsers and devices. WordPress might be trying to over-extend itself. Simply put sometimes simple is best.

    I think I would have preferred SEO and social media to be added for each page and post instead in WordPress rather than this new editor.

    Ramires

    (@ramiressilva)

    Gutemberg really was not the best choice for this new update, it’s very bureaucratic and wiped out WYSIWYG. I gave up and did as @redbullnik said, I downgraded to version 4.9.9. It’s working.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.