Support » Plugin: WP Data Access » No WordPress-Menu Item created

  • Resolved decentris

    (@decentris)


    Hi Peter,

    and it’s me again. 😉 Sorry for bothering you so often.

    But I have another issue:

    I successfully created a project and its pages and activated “Add to menu” (yes) but it doesn’t show up in the WordPress-Backend Menu.

    First I supposed it may be a conflict with another “menu-manipulating” plugin named “Menu Editor Pro” but I deactivated it, set up a new project and its pages (add to menu “yes”) and the project still doesn’t show up in the Backend menu.

    What could that be?

    Thanks for your help in advance, Peter.

    Best,
    Hannes

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Peter Schulz

    (@peterschulznl)

    Hi Hannes,

    You’re not bothering me! I love to see you working with my plugin. 🙂 That’s why I wrote it in the first place… 😉

    Did you add a role to your pages? It’s a new feature and I know it’s not yet documented, but you must enter at least one role for each page you want to be shown in the menu.

    Please add a role to each page in the page form and let me know if it works.

    Best regards,
    Peter

    decentris

    (@decentris)

    Hi Peter,

    yes I already supposed this so I assigned “administrator” and “editor” right when I set up the first page. But, as I said, it didn’t show up in the WP-Backend Menu.

    decentris

    (@decentris)

    PS: And, of course, I was logged in as “administrator”, which I assigned as a role so that it should show up in any case.

    Plugin Author Peter Schulz

    (@peterschulznl)

    Hi Hannes,

    There is a bug in release 2.0.8. This issue is solved in release 2.0.9. I prepared a pre-release of 2.0.9 for you. You can download it from here:
    https://drive.google.com/file/d/1Qj1wo6a2cvpbGaW7L5JWYRcxlPX7ulfM/view?usp=sharing

    Please let me know when you’ve downloaded it so I can take the link offline. And of course I am curious if this solution works for you…

    Keep in mind that once the final release 2.0.9 is out you will have to delete your installation of release 2.0.9 and reinstall it. DOn’t forget to export the plugin tables before you do.

    Best regards,
    Peter

    decentris

    (@decentris)

    Hi Peter,

    thank you for the update. Now the project – main menu is shown in the Backend-Menu but the Project-Pages (table, static, …) are not shown as sub-menus, so I cannot access them.

    There is still some bug here.

    Can you please have a look.

    Thanks a lot.

    Best,
    Hannes

    Plugin Author Peter Schulz

    (@peterschulznl)

    Hi Hannes,

    Can you export the project? There is an export link in the project row. If you click on it the project will be exported. Maybe you can sent me the file via a link?

    Best regards,
    Peter

    decentris

    (@decentris)

    Hi Peter,

    I was not able to export the project. When I click “Export” in the project row, it opens a window with the URL “javascript:jQuery(‘#stealth_mode’).attr(‘src’,’?action=wpdp_export_project&project_id=3&wpnonce=c686054328′)”

    and displays an empty white page with only one message on it: “[object Object]”

    Best,
    Hannes

    Plugin Author Peter Schulz

    (@peterschulznl)

    Hi Hannes,

    Which browser are you using? Could this be a browser incompatibility issue…?

    I’ve tested the plugin with Google Chrome, Mozilla FireFox and Microsoft Edge.

    Best regards,
    Peter

    decentris

    (@decentris)

    Hi Peter,

    you were right, it was an issue of my Firefox browser. In Chrome it worked like a charm.

    Here you are: https://drive.google.com/open?id=1_BH4Ioq6zyoi3kRZ3sKGytsC5YMKkM-m

    Best,
    Hannes

    • This reply was modified 6 months ago by  decentris.
    Plugin Author Peter Schulz

    (@peterschulznl)

    Hi Hannes,

    I imported your project. You main menu has two submenus in my browser.

    Strange… What do we do now? Some questions that might help us:
    + Do you see the submenus in the Chrome browser?
    + What platform are you working on?
    + What version of WordPress are you using?

    Best regards,
    Peter

    decentris

    (@decentris)

    Hmmm, strange…

    Now, it also shows the submenus…

    Don’t know why, maybe a Cache-Issue, but nevertheless it is working now.

    So we can close this, Peter.

    Thank you for your great support. 🙂

    Best,
    Hannes

    Plugin Author Peter Schulz

    (@peterschulznl)

    Great it’s working Hannes! 🙂

    I’ll close this topic. Thanks for being so patient. You’re helping me to improve the plugin.

    For the next release I’ll skip version number 2.0.9 and jump to 2.0.10 right away, so you’ll be notified when an update is available. Next time you update however, keep in mind that this will reset the roles for your project pages. This is because your data model is already updated to 2.0.9. Just update the roles for your pages and you should be good.

    Best regards,
    Peter

    decentris

    (@decentris)

    Perfect, Peter! 🙂

    Thanks for the great support.

    Looking forward to 2.0.10.

    Best,
    Hannes

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘No WordPress-Menu Item created’ is closed to new replies.