Support » Plugin: LiteSpeed Cache » No webp in Firefox

  • Resolved mmwbadmin

    (@mmwbadmin)


    Hi,

    I noticed webp version of images is shown in Chrome (75) but NOT in Firefox (68).
    Host uses LSWS. I use WP 5.2 with LSC plugin

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • LucasRolff

    (@lucasrolff)

    In Firefox version 66 and later do currently not advertise supporting “webp” because they don’t send it in their default ‘Accept’ Header. When they change this behavior back, webp will automatically get served again.

    The bug at Mozilla can be found here: https://bugzilla.mozilla.org/show_bug.cgi?id=1544231

    mmwbadmin

    (@mmwbadmin)

    Hi,

    Beats me. The Accept header reads: image/webp,*/* with Firefox 68.0.1

    and Accept: image/webp,image/apng,image/*,*/*;q=0.8 with Chrome 75
    on my site http://www.mmwb.nl.

    What’s wrong with the Firefox header?

    Until last Monday this worked fine under Firefox. I then used EWWW IO for webp conversion and WebP Express for displaying in the frontend. Worked fine in both Chrome and Firefox.

    Issue exists since I migrated Wednesday to a host with LSWS and use the LS Cache plugin.

    Plugin Support LiteSpeed Lisa

    (@lclarke)

    If the images were converted to WebP by some other means, then it’s possible they were saved with a different filename than LiteSpeed expects.

    For example, image.jpg becomes image.jpg.webp under LiteSpeed. If your WebP images are named similarly, LiteSpeed should find them and serve them where appropriate.

    If your files are named something else, like image.webp then LiteSpeed won’t discover them, and will not display them.

    Hope this helps!

    [Edited to add: I see you mentioned that the WebP images do display in Chrome. So, this naming issue is not what are experiencing. I should have read your original post more carefully. My apologies. I’ll leave this post here, in case it can help someone else, though.]

    • This reply was modified 1 year ago by LiteSpeed Lisa. Reason: Correction
    mmwbadmin

    (@mmwbadmin)

    Hi Lisa,

    I’m e.g. looking at
    uploads/2018/05/Paris-Streets-SocGen-sign.jpg.webp
    uploads/2019/07/logo-NS-150×150.jpg.webp
    uploads/2019/07/Arriva-trein-Limburg.png.webp
    uploads/2017/04/bussilh_header_nw_dark_se_light.jpg.webp

    First image being originaly converted by EWWW, the other three by LSC.
    After migration I had all 2176 images optimized by LS.

    Again, what’s wrong with the Firefox header?

    Regards,

    Wyb

    LucasRolff

    (@lucasrolff)

    @mmwbadmin

    The Accept header has to be sent as the default Accept header for the site – meaning the HTML document.

    The header sent in Firefox 68.0.1:

    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

    It’s correct that for images the Accept header Accept: image/webp,*/* is sent, but the logic whether images should be linked via webp or not happens within the HTML.

    In Google Chrome for example, the Accept header that is sent for the HTML document (the default Accept header) is Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8.

    As per the documentation here: https://developer.mozilla.org/en-US/docs/Web/HTTP/Content_negotiation/List_of_default_Accept_values#Default_values

    As you can see, they have a “Before”, “in Firefox 65” and “since Firefox 66” – and the issue lies in the removed image/webp since v66.

    mmwbadmin

    (@mmwbadmin)

    Hi Lucas,

    “meaning the HTML document” clarifies it for me.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No webp in Firefox’ is closed to new replies.