Support » Plugin: Webmention » No Webmention Support

  • Resolved Kev

    (@kevquirk)


    Webmentions have been working away just fine for months. I changed my theme a few days ago and now webmentions are broken.

    When I check Brid.gy, it just says “no webmention support <URL>”.

    At first I thought it might have been something wonky cached on my server, so I cleared that – still nothing. Then maybe I thought it might have been my security plugin (even though I’ve been using that for quite some time), so I disabled that – still nothing.

    I’ve tried disabling the webmention plugin and re-enabling – still nothing.

    I have no idea what’s happening here. Any ideas?

    Thanks,

    Kev

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor David Shanske

    (@dshanske)

    In order to find a webmention endpoint, the system looks in two places…the header(sent out by wordpress)…which could be intercepted by caching software. Second, in the head of the html file. It uses wp_head for this. If your new theme doesn’t have wp_head…

    You can check by going to the source, looking in header.php for the <head> tag and seeing if wp_head is there.

    Thanks for the quick reply, I really appreciate it.

    Checked my header file and wp_head is there:

    
    <!DOCTYPE html>
    <html <?php language_attributes(); ?> class="no-js no-svg">
    <head>
    	<meta charset="<?php bloginfo( 'charset' ); ?>">
    	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
    	<meta http-equiv="X-UA-Compatible" content="IE=edge">
    	<link rel="profile" href="http://gmpg.org/xfn/11">
    	<?php wp_head(); ?>
    	<?php echo alia_option('asalah_custom_header_code'); ?>
    </head>
    

    I’m using a child theme that doesn’t have the header.php as part of it, could that be it? (clutching at straws here).

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    I found the header on a single-post: view-source:https://kevq.uk/my-thoughts-on-pop-os-20-04-after-one-month/ but not on every post. Could it be that you have disabled pingbacks on the page you get errors with?

    Goodness me – as part of migrating to the new theme, I bulk enabled comments on all posts (I had them disabled on my previous theme). I wonder if I accidentally disabled pingbacks while I was at it.

    Anyway, I just enabled pingbacks on my latest post and I can see mentions starting to filter in.

    Thanks guys, I really do appreciate you responding so quickly. Keep up the great work!

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    No problem 😊

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.