Support » Plugin: GDPR » No way to link to privacy policy

  • Resolved Arthur

    (@aahkendall)


    I indicated a similar issue in my thread on the cookie banner, but in the settings all the text is plain text and it is impossible to put a simple html link in to the privacy policy.

    This should be automatic – otherwise I do not understand the purpose of specifying the Privacy Policy page, so maybe I am missing something. But both on the cookie consent banner and the registration form, it is insufficient to say “you have read and accept our privacy policy” – we need to link to it.

    Am I doing something wrong, or do I need to find a different plugin? Right now it’s almost useless I’m afraid.

    Thanks,
    Arthur

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Fernando Claussen

    (@fclaussen)

    Hi Arthur,

    The purpose of selecting the privacy policy page is to ask for consent again when the privacy policy gets updated.

    You are right, you should be able to add a link to your privacy page there. I can’t do it automatically because I want users to be able to set their own text.

    The text you normally would add to the bar should be an excerpt of why you use cookies and what do you use them for. A simple 3 liner should do. But I agree, a link to the privacy policy should be there. I’ll fix this on the next version set for today.

    Plugin Author Fernando Claussen

    (@fclaussen)

    Hi Arthur,

    I just pushed 1.0.4 and that version uses the link to the privacy policy page on the cookie bar and also on the cookie preferences window under “More information”.

    I also added an optional text you can add before. By default when activating the plugin, this value will be “Learn more at our”. The privacy policy link will come right after. This is optional tho. You can have just the link there if you’d like.

    I hope this takes care of your request. If you are still experiencing issues regarding this link, let me know and I’ll do my best to help you out.

    Hi Fernando,
    You certainly work quickly! Many thanks for all this.

    For some reason I am not seeing the banner at all (despite deliberately not clicking the I understand button on Firefox). I have tried deleting cookies and cache and restarting the browser, but I’m still not seeing it.

    The other thing I didn’t specify (I don’t think I’d finished setting everything up) is the same link is even more important on the registration page. We ask new users to sign up having read and accepted the policy but with no link.

    Frankly, simply enabling html in the registration message (and for that matter in the cookie consent window) would be fine for now – I’m trying to launch now(!)

    If you could possibly fix that I’d be hugely grateful!

    Many thanks again

    Plugin Author Fernando Claussen

    (@fclaussen)

    Hi Arthur,

    All I want is to help you guys get the best out of this. I dedicated weeks to make this happen and it devastates me that some of you are having trouble using it. That’s why I try to fix things as quickly as I can.

    You are probably not seeing the bar anymore because you might not have registered your cookie categories yet.

    If there is no content for the bar or if there is no cookie registered, the bar will not show. Before 1.0.4 it was just the bar content. I fixed this so you don’t end up with the bar and nothing on the actual window.

    Finish setting it up and it should show up again.

    While easier to enable html, blocking it is a security measure. If I can automate the process, that’s definitely the way to go imho.

    For this case in particular, I think it’s ok to enable a tags. So I’m going to enable them and change the default registration message to include the link on activation.

    Hold on. 1.0.5 is coming in a few minutes.

    Plugin Author Fernando Claussen

    (@fclaussen)

    Just updated the plugin to 1.0.5

    That should take care of this. You can now add “a” tags to your consent descriptions so you can link to your pages.

    Thanks for your feedback.

    Fantastic, thanks Fernando, you’re a star!

    Link working nicely on registration. One small request/suggestion for a future release, if possible (perhaps as part of automation) is to allow the target=”_blank” attribute to allow the privacy policy to open in a new page and avoid the dreaded back button and its “resending” warnings.

    As for the cookie categories, I’m a newbie at cookies (at least at a detailed level). Aside from “session” and “persistent”, I don’t really know how they are used on my site. God knows how other, regular bloggers and small site owners are expected to comply with this detailed information – and users won’t understand either!

    For now, I’m going to add some generic info on those two categories and hope that will suffice. Will keep you posted.

    Many thanks again, let me know how I can donate some beer money.

    Plugin Author Fernando Claussen

    (@fclaussen)

    Hi Arthur.

    If I’m not mistaken, I am allowing “target=”_blank” already. Give it a try.

    This whole thing can feel overwhelming. If you need some help setting everything up you can give us a shout at info@trewknowledge.com and someone here will get in touch with you.

    Even though we didn’t set up any way of donating beer money yet, an honest review of your experience with the plugin can help us a ton.

    Oh.. and don’t forget to check your other topic if you still can’t make the cookie settings window open up.

    Hi Fernando,

    I did already, hence the comment. I save and it gets deleted…

    Not a showstopper but one to look into.

    Thanks so much for the support. I think I have enough to get by for now, but once the site is up and running (and so publicly visible) I may well take you up on your offer.

    Re the other topic, you will see that your comments in this thread helped solve that problem too, so that’s marked as resolved too.

    Thanks again!

    Plugin Author Fernando Claussen

    (@fclaussen)

    Hi Arthur.

    You are right. I though I did enable “target” but I didn’t. I pushed a fix for you.

    Hi everybody,
    I know that this issue is finiseh, but I’m interested how Arturo(@aahkendall) get stop the cookies.
    Did you write any function in your wordpress?
    Where did you write it?
    Would you help me, please?
    I’m beginner about all related with programming and I’m lost enough.
    Any commney related to this were amazing.
    Thanks a lot

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘No way to link to privacy policy’ is closed to new replies.