Support » Plugin: Blackhole for Bad Bots » No warning message, no blocking when testing

  • Resolved amilford1977

    (@amilford1977)


    Greetings, and thanks for creating such a nice plugin.

    I’m struggling with implementation of this plugin on my WordPress site.

    1.) Robots.txt has been updated, and validated with the Google Search Console.
    2.) Any plugins remotely related to page caching have been disabled or uninstalled on my site.

    For testing, I have been connecting to the site from an Azure VM using a web browser. When visiting the blackhole URL, I receive no warning, and can continue accessing the site without any issue. I have checked that the IP address of this VM is NOT in the whitelist in the plugin settings.

    Questions:

    1.) Is there a way to determine if any other plugins could be blocking the init function you talk about in your documentation?
    2.) Do caching plugins have to be completely uninstalled, or can they simply be deactivated for Blackhole to work properly?
    3.) Any other troubleshooting measures you recommend I try?

    Thanks again!

Viewing 1 replies (of 1 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Glad to help:

    1) No sorry it’s not a current feature of the plugin

    2) Only certain cache plugins are incompatible with blackhole, here is a guide with more infos. And just deactivating a plugin is enough to disable it. So you can uninstall or deactivate, either is fine.

    3) Absolutely, I put together an entire in-depth guide on troubleshooting WordPress.

    Let me know if I can provide any further infos, glad to help anytime.

    • This reply was modified 3 weeks, 6 days ago by Jeff Starr. Reason: clarity
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.