no visual editor when writing ! (58 posts)

  1. diegoc
    Posted 8 years ago #


    I also need help!

    I am using wordpress 2.3.2 and I am having this same issue. The visual editor does not show up. I've tried many different things and I think the issue might be located on the server side. I can see the editor when using a wordpress version installed in a hosting company but I can't see the editor when using it on my own server. (same wordpress version)

    My server is: Windows XP runing Apache, PHP and MySQL (easyPHP package).

    I can't drag and drop widgets either. Any clues?


  2. diegoc
    Posted 8 years ago #

    OK - I found the issue. Apperently the built-in windows un-zip application does not unzip all files, specially those that handle widgets and the editors, which are .js files. So I used winrar instead to unzip the wordpress package and now it works fine. I had to use CRTL F5 to force a refresh.

  3. Graham Smith
    Posted 8 years ago #

    SHARE-IT Plugin
    I have found out that in my case, this plug-in causes the problem with the

      Visual Editor

    options disappearing. So please be wary of this potential clash.

    This is a huge problem already documented here in the forums.

    Since scouring the WordPress forum's about this I almost gave up with finding a cure. Simply, for 'apparently' no reason (and I use apparently loosley here) the Visual Editor would vanish. Now it seems there are several manifestation's of this. More...

    One is the actual Visual Editor would actually vanish completely, leaving you with just the Code tab.

    The other one, which I suffer from, would be that the actual Visual Editor menu options would disapear. So you still had the Visual Editor and Code tabs visible, but any way of actually selecting any of the (I will now use the abbreviation VE) VE options would be impossible, as there were not any to choose from.

    Leaving for a very frustrating time.

    It's a very common issue, with many contributory factors. Some are just messed up experimental coding, breaking WordPress. I know, I was a prime example of this.

    Others though, seem on the outside to be utterly random. I have seen people go to extreme lengths to remedy this issue, with no luck. There are some htings you can do that sometime's sorts the problem out, but ultimately, for the number of people, they are stuck without hope.
    Im don't have a miracle solution, but I do have a contributory cause in my particular experience, so it can be added to the one of many external factors.

    Simple, it was the Share It plug-in. Deactivate it, the VE would appear. Activate the Plug-in and the VE would disappear. Now I don't know why I didn't figure this out earlier. I thought I had de-installed all plug-ins as part of the elimination procedure, clearly not.

    But this is a reproducible error and is not a fluke.

    Hope this helps
    [sig moderated]

  4. scott-op
    Posted 8 years ago #

    Here's what worked for me. When I updated to 2.3.3 only the last 4 images in the visual editor's menu bar appeared, and they didn't work. I tried the suggestion given earlier to change the permission of the tinymce folder/directory (wp-includes/js/tinymce), changing it from 0775 to 0777. But when I went back to the Write Post page and refreshed it, all of the images disappeared, leaving only a white rectangle. I then changed the permission back to 0775, and when I refreshed the page again all of the images appeared and the editor now works fine. [Mac OS 10.2.8; Firefox]

  5. thoughtrocket
    Posted 8 years ago #

    I just wanted to throw my 2 cents in on this. I was having the same issue (no check box for visual editor on profile page and no visual editor to speak of). In my case it appears that when I uploaded the wordpress files to my server somehow the js folder was left out of the wp-includes folder. Since this folder houses the TinyMCE plugin, naturally without it I had no visual editor. I wish everyone else's issue with TinyMCE were as easy to fix. I put this here because I am hoping it will help somebody else. Thanks!

  6. apc33
    Posted 8 years ago #

    I've tried just about everything in this thread but simply cannot get the editor buttons to show up on Firefox (but they do show up on Safari). I'm using version 2.2.3 on a Mac.

    The fact that they work fine on Safari (3.0.4) but not on Firefox ( suggests to me that it is a browser compatibility issue. But why would it not work on Firefox?

    What should I do to fix the problem? I know I could upgrade to the latest wp version, but I've put so much effort into my current theme (which is incompatible with 2.3.3) recently that I want to hold off on having to change themes for a while.

    Any ideas would be warmly appreciated.

  7. apc33
    Posted 8 years ago #

    Actually, I'm realizing that the WYSIWYG editor is *not* working fine in Safari (even though the buttons appear) suggesting that there is a wordpress problem, not a browser issue.

    How do I solve this?

  8. rycklent
    Posted 8 years ago #

    I just experienced the "visual editor" bug on IE6.x/WinXP. I've been reading thrads on this for an hour.

    Turning off the pop-up blocker in IE turned on the visual editor -- both tabs and the editing icons returned. The visual editor was visible in Firefox 2.x in WinXP and OSX, also visible in Safari on OSX.

    I am guessing -- but I suspect various combinations of browser security settings, pop-up blocking and cross-domain access rules may be in play. My current fix includes:
    1) make the blog admin domain a "trusted site"
    2) set security in this zone to lowest (most open) setting)
    3) turn off popup blocking

    Your mileage (and browser experience) may vary.


  9. websitehelper
    Posted 8 years ago #

    diegoc: OK - I found the issue. Apperently the built-in windows un-zip application does not unzip all files

    VICTORY. Thanks, Diegoc! This solved my problem also. I just reinstalled the tinymce files using WinZip (same thing I used the first time). Something got corrupted the first time.

    I had been reading the forum for hours and saw that everyone was having different problems. The corrupted unzipping explains it all -- where different files did not load properly from the .zip file.

    For those who may not have seen my exact problem, here it is: Using IE7 and WordPress vs 2.3.3. Neither the "visual" or "code" tabs were displaying when writing or editing a post. Also, the toolbar did not display, even though I had the "use the visual editor when writing" turned on.

    Looking at all the posts, I was sure it was a bug since this has been out there for quite some time. You are a genius.

  10. AzzX
    Posted 8 years ago #

    Had a similar issue though the reason was my webhost has PHPSuExec installed.

    This means you need to create a php.ini file to allow certain functions.

  11. drraman007
    Posted 8 years ago #

    actually i am also having the same problem,tried evrything but didnt worked for me in fireforx,however setting security low helped me in IE

  12. willokeays
    Posted 8 years ago #

    None of this makes any sense to me .. but I too am having issues with the editor.

    I've tried several of your suggestions here - and nothing is working. I'm using Firefox and IE - the editor does not work in either version.

  13. ecword
    Posted 8 years ago #

    Confirming that the visual editor does NOT work under the following conditions:

    - Firefox
    - Windows XP
    - Removed .htaccess from /wp-includes
    - No applicable restrictions in other .htaccess files
    - "Use WYSIWYG" enabled for user
    - Uncompressed with WinRAR

    The problem I'm experiencing is that when I click on "Write," the editor box I'm presented with has the buttons for HTML editing, but "Visual" is highlighted. Clicking on either "Visual" or "HTML" does nothing... literally, there is no action or refreshing. Also, it appears that WP is automatically "fixing" my HTML... I have a plugin that needs "[sometext]" but when the page is saved it comes back with p tags attached, and the plugin breaks.

  14. willokeays
    Posted 8 years ago #

    I'll second what ecword is saying.

    My text editor does not look anything like this:

  15. ecword
    Posted 8 years ago #

    Holy hell, that look shiny. It also looks nothing like what I'm seeing, which is a single row of everything from "b" to "close tags" in the HTML editor, even though the whole reason I migrated from Drupal was to get a decent WYSIWYG editor.

    Honestly, I'm considering reverting to the previous WP version. I'm supposed to be rolling out a shiny new WP-based site for my college's newspaper today, and I really don't want to explain my my adviser how the new system botched its visual editor on the day of our launch.

  16. ecword
    Posted 8 years ago #

    I seem to have resolved things...

    - installed the Web Developer 1.1.5 addon for Firefox and disabled caching
    - deleted and re-uploaded /wp-includes
    - removed .htaccess restrictions (not that it matters, from a security perspective... the business blog I've developing is blank)

    The WYSIWYG editor seems to work now, and I can switch between that and the HTML editor with ease. I'll try narrowing down the source of the problem later.

  17. xxxevilgrinxxx
    Posted 8 years ago #

    I just had this problem crop up in 2.5.
    Apparently there was a clash between the editor and one of my plugins, Tiny Search and replace. Once I disabled the plug in, the editor came back. Don't know if that will help anyone else, or if I'm just lucky :)

  18. stevepierce
    Posted 8 years ago #

    Yep, I am having the same problem with 2.5.1. However, it is only with one blog. I have two on the same server, one works great, and the other doesn't. So this isn't a browser or computer problem. I have tested this from two different computers with IE and Firefox. No joy.

    This problem did not exist with 2.5 and it didn't happen until this week with 2.5.1. It used to work with 2.5.1.

    I am running IIS6. I have re-uploaded all the 2.5.1 files.

    Turned off all plug ins, No Joy.

    If I turn off Visual Editor, I get the B LINK and the rest of the HTML links. But turn Visual editor back on and no VE.

    I am suspecting this is a a db problem rather than a missing .js file or a CHMOD problem. Especially since it was working and then all of a suddenly stopped.

    - Steve

  19. pimpdaddy
    Posted 8 years ago #

    who has used the automatic upgrade plugin for this?

  20. pimpdaddy
    Posted 8 years ago #


    this happens for me ONLY if i use any IE browser.

    I have tested within Opera and Firefox both work correctly and as should, both post and upload etc.

    In my case it looks like IE is not compatable anymore which is a shame as at work (where i do all my posting)this is all we get to use.

  21. j_n
    Posted 8 years ago #

    The Configurable Tag Cloud plugin makes the visual editor crash too: the tab remains and it's highlighted, but the VE is unavailable. Try to deactivate it.

  22. rivermaya
    Posted 8 years ago #

    who has used the automatic upgrade plugin for this?

    I used WPAU for all my blogs, but few have this problems after I moved it to other server

  23. zelez
    Posted 8 years ago #

    I got mine working by UN-checking the "Visual Editor" box under "Users".
    Someone had said it had worked for them and sure enough... it's weird but it worked.

  24. discojing
    Posted 8 years ago #

    This is what I did to fix mine:

    - re-uploaded wp-includes directory
    - checked my profile to make sure "Use Visual Editor" box is checked
    - re-uploaded/updated Advanced Tiny MCE
    - logged out and cleared cleared cache and temporary internet files and then logged back in
    - this is what mine looks like now

  25. discojing
    Posted 8 years ago #

    p.s. some people say that it might be a problem with the WPLANG code--I deleted that from the config.php file.

  26. fluentdesigns
    Posted 8 years ago #

    thanks I had the same problem for the longest time and it was because of my user settings!

    thx again!

  27. RedComet
    Posted 8 years ago #

    Hello everyone.

    I am currently using 2.6.1 and have also been stumped by the same visual editor problem and tried everything mentioned in these posts to no avail.

    My problem turned out to be the Viper Video Quicktag plugin and disabling it wasn't enough, I had to delete the entire directory for that plugin. Despite being an up-to-date version of the plugin it was definitely conflicting with the WP editing window.

    As it turns out, the WP WYSIWYG editor is plenty useful enough anyway.

    Thanks for everyone's suggestions and good luck.

  28. dracco
    Posted 7 years ago #

    For those who still have problems with Visual Editor not showing: I've done some debuging and I've found that when post-new.php page tries to load http://www.mysite.com/wp-includes/js/tinymce/tiny_mce_gzip.php and http://www.mysite.com/wp-includes/js/tinymce/tiny_mce_config.php, the server throws a 404 error code (Not Found). If I try to inspect these included files in Firebug (even try to open them directly in a browser) I'll recieve the typical "This page is not found" with my template, my colours, etc.

    These files exists in the requested paths, so I guess there is some bad redirecting when requests come.

    If I try this with original Javascript files (with JS extension, not PHP extension), they are opened as expected (prototype.js, for example, is returned fine). The file http://www.mysite.com/wp-includes/js/tinymce/tiny_mce.js is returned OK as well

    I've tried to insert a .htaccess rule like the following just below the RewriteBase / line (yes, it seems do nothing, only stop processing .htaccess when it is TRUE):

    RewriteRule /wp-includes/js/(.*) /wp-includes/js/$1 [l]

    But unfortunatelly this not work. I'm sure my problem comes with paths, even this issue appeared suddenly one day without doing any change. Maybe the hosting had done any change, but now it's impossible to track them back.

    Any WordPress / PHP guru can help me? any idea would be appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic